HUST 1602 - Substring

题目描述
This problem is quiet easy.
Initially, there is a string A.

Then we do the following process infinity times.
A := A + “HUSTACM” + A

For example, if a = “X”, then
After 1 step, A will become “XHUSTACMX”
After 2 steps, A will become “XHUSTACMXHUSTACMXHUSTACMX”

Let A = “X”, Now I want to know the characters from L to R of the final string.
输入
Multiple test cases, in each test case, there are only one line containing two numbers L and R.
1 <= L <= R <= 10^12
R-L <= 100
输出
For each test case, you should output exactly one line which containing the substring.
样例输入
5 10
样例输出
TACMXH

#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>

using namespace std;
long long int l,r;
char a[9];
int main()
{
    a[0]='H';
    a[1]='U';
    a[2]='S';
    a[3]='T';
    a[4]='A';
    a[5]='C';
    a[6]='M';
    a[7]='X';
    while(scanf("%lld%lld",&l,&r)!=EOF)
    {
        int pos;
        if(l==1)
            pos=7;
        else
            pos=(l-2)%8;
         int cnt=1;
         while(cnt<=(r-l)+1)
         {
             printf("%c",a[(pos)%8]);
             pos++;
             cnt++;
         }
         printf("\n");


    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228783.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值