HUST 1602 Substring

Description

This problem is quiet easy. 
Initially, there is a string A. 
  
Then we do the following process infinity times. 
 A := A +   “HUSTACM” + A 
  
For example, if a = “X”, then 
After 1 step, A will become   “XHUSTACMX”
After 2 steps, A will become   “XHUSTACMXHUSTACMXHUSTACMX”
  
Let A = “X”, Now I want to know the characters from L to R of the final string.

Input

Multiple test cases, in each test case, there are only one line containing two numbers L and R. 
1 <= L <= R <= 10^12 
R-L <= 100

Output

For each test case, you should output exactly one line which containing the   substring.

Sample Input

5 10

Sample Output

TACMXH

其实生成的串本身就是无限循环的,循环节就是8,所以直接算出L对应的位置就好了。

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e5+10;
LL l,r;
char s[10]={"XHUSTACM"};

int main()
{
	while (~scanf("%lld%lld",&l,&r))
	{
		int len=r-l+1;
		for (int i=0;i<len;i++)
		{
			printf("%c",s[(i+(l-1)%8)%8]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值