A1031 Hello World for U (20)(20 分)

A1031 Hello World for U (20)(20 分)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~

  • n~2~ + n~3~ - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路

005yt5eJgy1fts6jn5d6zj31kw23ve8b

第二种方法,获取上界,编程就是解放人脑啊。

AC代码

#include <stdio.h>
#include <string.h>
int main() {
    char str[100], ans[40][40];//这里二维数组开到30也可以的吧 
    gets(str);//读入一行字符串 
    int N = strlen(str);//获取字符串的长度 
    int n1 = (N + 2) / 3, n3 = n1, n2 = N + 2 - n1 - n3;//自动向下取整
    for(int i = 1; i <= n1; i++) {
        for(int j = 1; j <= n2; j++) {
            ans[i][j] = ' ';//初始化,将ans数组全部赋值为空格 
        }//第i行第j列 
    }
    int pos = 0;
    for(int i = 1; i <= n1; i++) {
        ans[i][1] = str[pos++];
    }
    for(int j = 2; j <= n2; j++) {
        ans[n1][j] = str[pos++];
    }
    for(int i = n3 - 1; i >= 1; i--) {
        ans[i][n2] = str[pos++];
    }
    for(int i = 1; i <= n1; i++) {
        for(int j = 1; j <= n2; j++) {
            printf("%c", ans[i][j]);
        }
        printf("\n");
    }
    return 0;
}
#include <stdio.h>
#include <string.h>
int main() {
    char str[100];
    gets(str);
    int N = strlen(str);
    int n1 = (N + 2) / 3, n3 = n1, n2 = N + 2 - n1 - n3;
    for(int i = 0; i < n1 - 1; i++) {//前n1-1行 
        printf("%c", str[i]);
        for(int j = 0; j < n2 - 2; j++) {
            printf(" ");//n2-2个空格 
        }
        printf("%c\n", str[N - 1-i]); 
    }
    for(int i = 0; i < n2; i++) {
        printf("%c", str[n1 + i - 1]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/lingr7/p/9392779.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值