PAT 甲级 图形输出 1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 我的思路:

取字符串的总长度,看是否能整除3,(令整除3的商为a,余数为b)

如果能,n1部分长度取a,n2部分长度取a+2,n3部分长度为a,

如果不能,n1部分长度取a+1,n2部分长度取a+b,n3部分长度为a+1

具体看代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
	string s;
	int len=0;
	int i,j,k,t;
	cin>>s;
	len=s.length();
	if(len%3==0)
	{
		k=len/3;
		j=0;
		for(i=0;i<k;i++)
		{
			if(i!=k-1)
			{
				printf("%c",s[j]);
				for(t=0;t<k;t++)
				{
					printf(" ");
				}
				printf("%c",s[len-j-1]);
			}
			else
			{
				for(t=0;t<k+2;t++)
				printf("%c",s[t+j]);
			}
			j++;
			printf("\n");
		}
	}
	else
	{
		k=len/3;
		j=0;
		for(i=0;i<k;i++)
		{
			printf("%c",s[j]);
			for(t=0;t<k+len%3-2;t++)
			{
				printf(" ");
			}
			printf("%c",s[len-j-1]);
			j++;
			printf("\n");
		}
		for(i=0;i<k+len%3;i++)
		{
			printf("%c",s[j+i]);
		}
		printf("\n");
	}
	return 0;
}

别人的代码:

我每次几乎每次都找一个比自己简洁的代码

但我真的佩服这位博主的代码


方法:求出字符串长度 n , 然后得 m = n+2
          然后再得到 n1=n3=m/3,同时n2 = m - n1*2;
我写的代码中求出的n2是比上面的n2少2.

#include <bits/stdc++.h> 
using namespace std;
int main() {
	//freopen("datain.txt","r",stdin); 
	string s;
	cin>>s;
	int n = s.length();
	//cout<<n<<endl;
	int n1 = (n+2)/3;
	int n2 = n-n1*2;
	//cout<<n1<<" "<<n2<<endl;
	string s1 = s.substr(0,n1);//n1字符串
	string s2 = s.substr(n1,n2);//n2字符串
	string s3 = s.substr(n1+n2);//n3字符串
	//cout<<s1<<" "<<s2<<" "<<s3<<endl;
	for (int i = 0; i < n1; i++) {
		cout<<s1[i];
		for (int j = 0; j < n2; j++) {
			if (i != n1-1) //中间空格 
				cout<<" ";
			else //最后一行
				cout<<s2[j];
		}
		cout<<s3[n1-i-1]<<endl;
	}
	return 0;
}

加油!

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值