Don't Be a Subsequence

本文介绍了一种算法,用于找出给定字符串中最短且字典序最小的非子序列字符串。通过从后向前分割字符串,并确保每个区间内包含一套完整的a-z字母,从而有效地解决了问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

时间限制: 1 Sec  内存限制: 128 MB
题目描述
A subsequence of a string S is a string that can be obtained by deleting zero or more characters from S without changing the order of the remaining characters. For example, arc, artistic and (an empty string) are all subsequences of artistic; abc and ci are not.
You are given a string A consisting of lowercase English letters. Find the shortest string among the strings consisting of lowercase English letters that are not subsequences of A. If there are more than one such string, find the lexicographically smallest one among them.

Constraints
1≤|A|≤2×10 5
A consists of lowercase English letters.

输入
Input is given from Standard Input in the following format:
A

输出
Print the lexicographically smallest string among the shortest strings consisting of lowercase English letters that are not subsequences of A.

样例输入
atcoderregularcontest

样例输出
b

提示

The string atcoderregularcontest contains a as a subsequence, but not b.


来源/分类

ABC071&ARC081 

GPLv2 licensed by HUSTOJ 2018


题意是让你找最短的且字典序最小的,不是S子序列的序列。

考虑从后向前分割区间,每个区间包含且只包含一套a-z的字母。设每个区间的左右端点为Li,Ri。

若分割成的完整的区间个数为cut,那么易知ans=cut+1。

考虑答案串的第一个字母,如果第一个字母在[0 ,  L0)里出现过,那么以这个字母开头的长度为cut+1的所有串都在S中出现过。

因此,答案的第一个字母是[0 ,  L0)里没出现过的字母。

考虑答案的第二个字母,设第一个字母在S中第一次出现的位置为x,那么若第二个字母取区间[x+1  , R1]里的字母,那么以这个字母开头的所有长度为cut的串都在S中出现过。再加上答案的第一个字母,因此以这两个字母开头的答案为cut+1的串都在S中出现过,因此答案的第二个字母要取[x+1  , R1]里没出现的字母。

以此类推,再贪心选择即可得到答案串。

#include<bits/stdc++.h>
#define N 250000
using namespace std;

int L[N],R[N],ans=0;
int check[30]={0};

int main()
{
    char s[N];
    scanf("%s",s);
    int len=strlen(s);
    int now=26;
    R[0]=len-1;


    for(int i=len-1;i>=0;i--)
    {
        if(!check[s[i]-'a'])
        {
            now--;
            check[s[i]-'a']=1;

            if(now==0)
            {
                L[ans]=i;
                ans++;
                R[ans]=i-1;
                now=26;
                memset(check,0,sizeof(check));
            }
        }
    }
    L[ans]=0;
    int last=0;
    char ans_now;

    for(int i=ans;i>=0;i--)
    {
        int now=26;
        memset(check,0,sizeof(check));

        for(int j=last;j<=R[i];j++)check[s[j]-'a']=1;

        for(int j=0;j<26;j++)
        if(!check[j])
        {
            printf("%c",j+'a');
            ans_now=j+'a';
            break;
        }

        for(int j=last;j<len;j++)if(s[j]==ans_now)
        {
            last=j+1;
            break;
        }

    }
return 0;
}
/*
abcdefghijklmnopqrstuvwxyz
*/
View Code

 

转载于:https://www.cnblogs.com/tian-luo/p/9382462.html

<think>好的,用户遇到了关于PyTorch的FutureWarning,想解决torch.load的安全问题,需要消除警告并正确设置weights_only参数。首先,我需要回忆相关的知识。根据用户提供的引用,特别是引用[1]和[2],未来版本的PyTorch会默认将weights_only设为True,以提高安全性,避免执行任意代码。当前用户可能使用的是较新版本的PyTorch,但设置可能还是weights_only=False,导致警告出现。 用户的目标是消除这个警告,并正确配置参数。解决方案的关键在于显式设置weights_only=True。引用[2]提到,建议显式设置这个参数。所以,用户需要修改他们的torch.load调用,添加weights_only=True。例如,原来的代码可能是torch.load('model.pth'),现在需要改为torch.load('model.pth', weights_only=True)。 不过,还需要注意兼容性问题。如果用户加载的模型包含除了张量以外的对象,比如自定义类或函数,设置weights_only=True可能会导致错误,因为此时PyTorch只允许加载包含张量的模型。这时候需要检查模型文件是否安全,或者是否有必要保留这些非张量数据。如果必须加载这些对象,可能需要重构模型保存方式,或者暂时保持weights_only=False,但需注意安全风险。 另外,用户提到引用[3]关于更改缓存目录的问题,这可能和当前问题无关,但需要确保模型路径正确,避免加载错误。此外,引用[4]中的subsequent_mask函数可能与模型结构有关,但当前问题主要集中在加载模型时的参数设置。 接下来,用户可能需要按照步骤操作:首先检查PyTorch版本,确保是支持weights_only参数的版本(如2.0.0及以上)。然后修改加载代码,添加参数。如果遇到错误,需要判断是否因为模型含有非张量数据,进而采取相应措施,比如重新保存模型仅存储状态字典,而不是整个模型对象。 最后,用户可能需要测试修改后的代码,确认警告是否消除,同时模型能正确加载。如果问题仍然存在,可能需要考虑降级PyTorch版本或进一步调整代码。</think>### 分步解答:消除 `torch.load` 的 FutureWarning 并设置安全参数 #### 1. **理解警告原因** PyTorch 的 `torch.load()` 默认使用 `pickle` 模块加载模型,这可能执行任意代码,存在安全隐患。未来版本将默认启用 `weights_only=True`,限制仅加载张量数据而非代码[^1][^2]。 --- #### 2. **显式设置 `weights_only=True`** 在调用 `torch.load()` 时添加参数 `weights_only=True`,强制仅加载模型权重: ```python model = torch.load("model.pth", weights_only=True) # 显式启用安全模式 ``` --- #### 3. **处理兼容性问题** * **情况1**:若模型仅包含张量(如通过 `torch.save(model.state_dict(), ...)` 保存),直接设置 `weights_only=True` 即可。 * **情况2**:若模型包含非张量对象(如自定义类),需重构代码: ```python # 安全保存(仅保存状态字典) torch.save(model.state_dict(), "model_weights.pth") # 安全加载 model = MyModel() # 需先实例化模型结构 model.load_state_dict(torch.load("model_weights.pth", weights_only=True)) ``` --- #### 4. **验证 PyTorch 版本** 确保 PyTorch 版本 ≥ 2.0.0(支持 `weights_only` 参数): ```python print(torch.__version__) # 建议版本 ≥ 2.0.0 ``` 若版本过低,升级或降级到兼容版本: ```bash pip install torch==2.0.0 # 示例指定版本 ``` --- #### 5. **彻底消除警告(可选)** 若仍看到警告,可通过过滤警告忽略: ```python import warnings warnings.filterwarnings("ignore", category=FutureWarning, message=".*weights_only.*") ``` --- ### 关键总结 | 步骤 | 操作 | 目的 | |------|------|------| | 1 | 添加 `weights_only=True` | 启用安全加载模式 | | 2 | 检查模型保存方式 | 确保仅含张量数据 | | 3 | 验证 PyTorch 版本 | 兼容性保障 | ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值