hdu 4496 并查集 反向并查集 水题 D-City

觉得这道题以后可以和优先队列结合起来 嗯

就是说依次去掉前n条路求连通块数量

 

处理的时候  只要每次merge发现父亲不相等 然后进到里面合并的时候 num--

wa了好几次是因为最后输出的时候开了点的数量大小的数组而不是操作数量数组 orz

 

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5334    Accepted Submission(s): 1864


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

 

Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

 

Sample Output
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 
 
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>

using namespace std; 

const int MAXN = 10000;
const int MAXM = 100000;
int father[MAXN + 100];
int u[MAXM + 100];
int v[MAXM + 100];
int ans[MAXM + 100];
int n,m,num;

void initt(){
    for(int i = 0;i < n;i++){
        father[i] = i;
    }
    return;
}

int findd(int u){
    if(father[u] == u)
        return father[u];
        
    father[u] = findd(father[u]);
    return father[u];
}
void mergee(int u,int v){
    int fatu = findd(u);
    int fatv = findd(v);
    if(fatu != fatv){
        num--;
        father[fatu] = fatv;
    }
}

int main(){
    while(~scanf("%d%d",&n,&m)){
        //initt();
        for(int i = 0;i < n;i++){
            father[i] = i;
        }
        for(int i = 0;i < m;i++){
            scanf("%d%d",u+i,v+i);
        }
        
        num = n;
        for(int i = m-1;i >= 1;i--){
            mergee(u[i],v[i]);
            ans[i] = num;
        }
        ans[m] = n;
        for(int i = 1;i <= m;i++){
            printf("%d\n",ans[i]);
        }
    }
    
    return 0;
}

 

 

转载于:https://www.cnblogs.com/xuyanqd/p/9028854.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值