hdu D-City 反向并查集

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2134    Accepted Submission(s): 751


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 


 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 


 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 


 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 


 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

 

 

 题目大意:给你n个顶点,m条边。每次会摧毁一条边,到最后把m条边都摧毁完。问你每次摧毁的时候还有几个集合。


            解题思路:边会逐渐摧毁,我们关心的是点上还连着多少边。摧毁1条边还有m-1条边,摧毁2条边还有m-2条边。我们可以直接使用并查集处理,从后往前处理,依次加上第m条边,第m-1条边。这样处理即可。不过需要在找father的时候压缩路径,不然会TLE详见代码。
 
反向并查集

#include<stdio.h>
#include<string.h>
int p[1000010];
int res[1000010];
int sum;
struct inin
{
	int b;
	int e;
}boy[1000010];
int find(int n)
{
	return p[n]==n ? n : p[n]=find(p[n]);
}
int main()
{
	int n,m;
	int i,j;
	int u,v;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<=n;i++)
		  p[i]=i;
		 //sum=n;
		for(i=m-1;i>=0;i--)
		{
			scanf("%d%d",&u,&v);
			boy[i].b=u;
			boy[i].e=v;
		}
		sum=0;
		for(i=0;i<m;i++)//从最后开始拆 
		{
			int f1=find(boy[i].b);
			int f2=find(boy[i].e);
			if(f1!=f2)
			{
				p[f1]=f2;
				sum++;//拆掉 
			}
			//建立点数
			res[i+1]=n-sum;
		}
		res[0]=n;
		for(i=m-1;i>=0;i--)
		{
			printf("%d\n",res[i]);
		}
	}
return 0;
}


 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值