TOJ 2814 Light Bulb

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

Source

ZJCPC 2009

 

cjx几何学的差,解不出来。发现大家都用的是三分法。第一次接触了三分法学习了一下。

三分法是一个求先单调递增然后单调递减的峰值的一个方法。可以看下下面的函数。

 

double work(double left , double right){
    while( fabs(left-right)>eps ){
        double mid=(left+right)/2;
        double midmid=(mid+right)/2;
        if(cal(mid)<=cal(midmid)){
            left=mid;
        }else{
            right=midmid;
        }
    }
    return left;
}

 

对于这题嘛!我们可以根据三角形的相似性列得这样的一个方程:l1/D=(h-l2)/(H-l2)=> l1=(h-l2)/(H-l2)*D

l1+l2=(h-l2)/(H-l2)*D+l2  (0<l2<h)  注:l1为投射到地面的影子长度,l2为投射到墙上的影子长度。

 

#include <stdio.h>
#include <math.h>
#define eps 1e-8 

double H,h,D;
//影子长度的计算公式 
double cal(double l){
    return D*(h-l)/(H-l)+l;
}

int main()
{    
    int t;
    scanf("%d" ,&t);
    while( t-- ){
        scanf("%lf %lf %lf" ,&H ,&h ,&D);
        double left=0;
        double right=h;
        while( fabs(left-right)>eps ){
            double mid=(left+right)/2;
            double midmid=(mid+right)/2;
            if(cal(mid)<=cal(midmid)){
                left=mid;
            }else{
                right=midmid;
            }
        }
        printf("%.3lf\n",cal(left));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/chenjianxiang/p/3598190.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值