三分法(例题)

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

 

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

 

Output

 

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

 

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

 

 

#include<stdio.h>
#define eps  1e-6
#define ll long long
using namespace std;
double H,h,d;
double f(double pos)
{
    return pos+(H*pos-h*d)/(pos-d);//推出的公式:相当于一个 x+一个关于x的函数,通过三分对x进行遍历。
}
double solve(double l,double r)
{
    double mid,midmid;
    while(r-l>=eps)                直到l,和r足够小 即自变量的左右端点可以看作重叠时 可理解为全部遍历完了 (背过这段代码)
    {
        mid=(l+r)/2.0;
        midmid=(r+mid)/2.0;
        if(f(mid)>f(midmid))
        {
            r=midmid;
        }
        else
            l=mid;

    }
    return f(l);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double ans=0;
        scanf("%lf%lf%lf",&H,&h,&d);
        ans=solve(0,d*(h/(H*1.0)));//第一次三分时 自变量的取值范围
        printf("%.3lf\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值