ZOJ Problem Set - 1879

ZOJ Problem Set - 1879
Jolly Jumpers

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.


Input

Each line of input contains an integer n < 3000 followed by n integers representing the sequence.


Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".


Sample Input

4 1 4 2 3
5 1 4 2 -1 6


Sample Output

Jolly
Not jolly


Source: University of Waterloo Local Contest 2000.09.30

//简单模拟题

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
bool hash[3002];
int a[3002];
int main()
{
    int n,i;
    bool f;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
         scanf("%d",&a[i]),hash[i]=0;
        for(f=1,i=2;i<n;i++)
        {
            if(a[i]>a[i-1])
            {
                if(a[i]-a[i-1]>=n||a[i]-a[i-1]<1)
                   {
                       f=0;break;
                   }
               if(!hash[a[i]-a[i-1]])
                 hash[a[i]-a[i-1]]=1;
                else
                {
                    f=0;break;
                }
            }
            else
            {
               if(a[i-1]-a[i]>=n||a[i-1]-a[i]<1)
                   {
                       f=0;break;
                   }
               if(!hash[a[i-1]-a[i]])
                 hash[a[i-1]-a[i]]=1;
                else
                {
                    f=0;break;
                }
            }
        }
        if(f) printf("Jolly\n");
        else printf("Not jolly\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/372465774y/archive/2012/08/01/2618411.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值