UVa 11388 - GCD LCM

Description

The GCD of two positive integers is the largest integer that divides both the integers without any remainder. The LCM of two positive integers is the smallest positive integer that is divisible by both the integers. A positive integer can be the GCD of many pairs of numbers. Similarly, it can be the LCM of many pairs of numbers. In this problem, you will be given two positive integers. You have to output a pair of numbers whose GCD is the first number and LCM is the second number.

Input

The first line of input will consist of a positive integer T . T denotes the number of cases. Each of the next T lines will contain two positive integer, Gand L.

Output

For each case of input, there will be one line of output. It will contain two positive integers a and b, a≤b,which has a GCD of Gand LCM of L. In case there is more than one pair satisfying the condition, output the pair for which a is minimized. In case there is no such pair, output ‘-1’.

Constraints

  • T ≤ 100
  • Both G and Lwill be less than \(2^{31}\).

Sample Input

2
1 2
3 4

Sample Output

1 2
-1

Resume

输入两个整数G、L,求两个数a、b使得其最大公因数和最小公倍数分别为G、L。
若存在多组a、b,输出a最小的一组。
若不存在这种a、b,输出-1。

Analysis

在没有认真读题的时候,觉得这个可能要暴力枚举判断。但既然是a最小的一组,那必然是G、L本身,前提是L%G == 0。

Code

//
//Target: UVa 11388 - GCD LCM
//@Author: Pisceskkk
//Date: 2019-2-16
//

#include<cstdio>
#define ll long long
using namespace std;

ll a,b,l,g,d;
int t;
bool ok;

int main(){
    scanf("%d",&t);
    while(t--){
        ok = 1;
        scanf("%lld %lld",&g,&l);
        if(l%g != 0){
            printf("-1\n");
            continue;
        }
        else {
            printf("%lld %lld\n",g,l);
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/pisceskkk/p/10417632.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值