LightOJ - 1236 Pairs Forming LCM

Find the result of the following code:


long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}


A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).


Input
Input starts with an integer T (≤ 200), denoting the number of test cases.


Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).


Output
For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.


Sample Input
15
2
3
4
6
8
10
12
15
18
20
21
24
25
27
29
Sample Output
Case 1: 2
Case 2: 2
Case 3: 3
Case 4: 5
Case 5: 4
Case 6: 5
Case 7: 8
Case 8: 5
Case 9: 8
Case 10: 8
Case 11: 5
Case 12: 11
Case 13: 3
Case 14: 4

Case 15: 2

求小于等于n的数中最小公倍数等于N的组合而且 i<=j  ;

#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<map>
#include<iostream>
#include<string.h>
#include<algorithm>
#define maxn 1000005
#define maxm 10000005
#define MAXN 100005
#define MAXM 10005
#define mem(a,b) memset(a,b,sizeof(a))
#define ll unsigned long long
#define inf 0x3f3f3f3f
using namespace std;
bool vis[maxm+5];
ll tot;
ll p[maxn];
void get_prime(){
     tot=0;
    mem(vis,true);
    for(ll i=2;i<=maxm;i++){
        if(vis[i]){
            p[tot++]=i;
            for(ll j=i*i;j<=maxm;j+=i)vis[j]=false;
        }
    }
}
ll f(ll n){
    if(n==1)return 1;
    ll ans=1;
    for(int i=0;i<tot;i++){
        if(n%p[i]==0){
            ll x=0;
           while(n%p[i]==0){x++;n/=p[i];}
            ans*=(2*x+1);
        }
    }
    if(n!=1)ans*=(2*1+1);
    return ans/2+1;
}
int main(){
    get_prime();
    int t,test=0;
    scanf("%d",&t);
    while(t--){
    ll n;
    scanf("%lld",&n);
   printf("Case %d: %lld\n",++test,f(n));
    }
}

转载于:https://www.cnblogs.com/da-mei/p/9053225.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值