HDU1078-dp和dfs结合

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13270    Accepted Submission(s): 5549


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
 
 
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
 
 
37

题意:一只老鼠吃奶酪,给你n*n的地图,地图上的数字表示奶酪的数量,老鼠一次能走最多k步,但是每次走到一个地方的奶酪数量要比之前的多,问,老鼠最多吃多少奶酪。

思路:我们可以用dp保存数据和标记,用dfs搜索。

坑点:无

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=110;
int map[maxn][maxn],dp[maxn][maxn];
int n,k,dir[4][2]={0,1,0,-1,1,0,-1,0};
int dfs(int x,int y)
{
    int i,j,sum=0;
    int nx,ny;
    if (dp[x][y]==0)        //dp[x][y]==0表示没有走过这里,标记
        {
            for (i=1;i<=k;i++)
                for (j=0;j<4;j++)
                    {
                        nx=x+dir[j][0]*i;            //最多可以走k步
                        ny=y+dir[j][1]*i;
                        if (nx<=0||nx>n||ny<=0||ny>n)        //越界处理
                            continue;
                        if (map[nx][ny]>map[x][y])        //奶酪数量多的点再进行dfs
                            sum=max(sum,dfs(nx,ny));
                    }
            dp[x][y]=map[x][y]+sum;                    //dp[x][y]表示的是从这点出发最多能吃多少奶酪
        }
    return dp[x][y];
}
int main()
{
    int i,j,ans;
    while (cin>>n>>k&&(n!=-1&&k!=-1))
        {
            memset(map,0,sizeof(map));
            for (i=1;i<=n;i++)
                for (j=1;j<=n;j++)
                    cin>>map[i][j];
            memset(dp,0,sizeof(dp));
            ans=dfs(1,1);
            cout<<ans<<endl;
        }
    return 0;
}
发现这种多个算法一起来写一个代码的感觉很舒服
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值