hdu 5950 Recursive sequence 矩阵快速幂

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
 

 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
 

 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

 

Sample Input
2 3 1 2 4 1 10
 

 

Sample Output
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.
 

 

Source
  套板子,取模开ll就好了;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=2e5+10,M=1e6+10,inf=1e9+10;
const ll INF=1e18+10,MOD=2147493647;
struct Matrix
{
    ll a[10][10];
    Matrix()
    {
        memset(a,0,sizeof(a));
    }
    void init()
    {
        for(int i=0;i<7;i++)
            for(int j=0;j<7;j++)
                a[i][j]=(i==j);
    }
    Matrix operator + (const Matrix &B)const
    {
        Matrix C;
        for(int i=0;i<7;i++)
            for(int j=0;j<7;j++)
                C.a[i][j]=(a[i][j]+B.a[i][j])%MOD;
        return C;
    }
    Matrix operator * (const Matrix &B)const
    {
        Matrix C;
        for(int i=0;i<7;i++)
            for(int k=0;k<7;k++)
                for(int j=0;j<7;j++)
                    C.a[i][j]=(C.a[i][j]+(a[i][k]*B.a[k][j])%MOD)%MOD;
        return C;
    }
    Matrix operator ^ (const ll &t)const
    {
        Matrix A=(*this),res;
        res.init();
        int p=t;
        while(p)
        {
            if(p&1)res=res*A;
            A=A*A;
            p>>=1;
        }
        return res;
    }
};
Matrix base,hh;
void init()
{
    base.a[0][0]=1;
    base.a[1][0]=2;
    base.a[2][0]=1;
    base.a[0][1]=1;
    base.a[2][2]=1;
    base.a[3][2]=4;
    base.a[4][2]=6;
    base.a[5][2]=4;
    base.a[6][2]=1;
    base.a[3][3]=1;
    base.a[4][3]=3;
    base.a[5][3]=3;
    base.a[6][3]=1;
    base.a[4][4]=1;
    base.a[5][4]=2;
    base.a[6][4]=1;
    base.a[5][5]=1;
    base.a[6][5]=1;
    base.a[6][6]=1;
}
void init1(ll a,ll b)
{
    memset(hh.a,0,sizeof(hh.a));
    hh.a[0][0]=b%MOD;
    hh.a[0][1]=a%MOD;
    hh.a[0][2]=3*3*3*3;
    hh.a[0][3]=3*3*3;
    hh.a[0][4]=3*3;
    hh.a[0][5]=3;
    hh.a[0][6]=1;
}
int main()
{
    init();
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        ll n,a,b;
        scanf("%lld%lld%lld",&n,&a,&b);
        init1(a,b);
        Matrix ans=(base^(n-2));
        hh=hh*ans;
        printf("%lld\n",hh.a[0][0]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/6017281.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值