HDU 5950 Recursive sequence(矩阵快速幂)

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29    Accepted Submission(s): 19


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

题意:

已知递推公式为F(n)=F(n-1)+F(n-2)+n^4,F(1)=a,F(2)=b,给出n,求出F(n)。

思路:

一道矩阵快速幂的裸题,难点在于由已知的递推式构造矩阵,大家应该大一都学了线性代数,构造矩阵也就不难了,具体的步骤就不说了。

代码:

#include<iostream>
#include<cstring>
using namespace std;
#define mod 2147493647
#define LL long long
struct matrix{
    LL m[7][7];
}mat;
int t,n,f1,f2;

void init(){
    memset(mat.m,0,sizeof(mat));///此处也可以用一个初始化的二维数组通过来赋值,避免一个一个麻烦的赋值。
    mat.m[0][1]=1,mat.m[1][0]=2,mat.m[1][1]=1,mat.m[1][2]=1,mat.m[1][3]=4,mat.m[1][4]=6,mat.m[1][5]=4,mat.m[1][6]=1;
    mat.m[2][2]=1,mat.m[2][3]=4,mat.m[2][4]=6,mat.m[2][5]=4,mat.m[2][6]=1;
    mat.m[3][3]=1,mat.m[3][4]=3,mat.m[3][5]=3,mat.m[3][6]=1;
    mat.m[4][4]=1,mat.m[4][5]=2,mat.m[4][6]=1;
    mat.m[5][5]=mat.m[5][6]=mat.m[6][6]=1;
}

matrix mul(matrix a,matrix b){
    matrix c;
    memset(c.m,0,sizeof(c.m));
    for(int i=0; i<7; i++)
        for(int j=0; j<7; j++)
            for(int k=0; k<7; k++)
                c.m[i][j]=(c.m[i][j]+a.m[i][k]*b.m[k][j])%mod;///注意要使用long long因为此处可能会越界。
    return c;
}

int slove(){
    matrix ans;
    memset(ans.m,0,sizeof(ans.m));
    ans.m[0][0]=f1,ans.m[1][0]=f2,ans.m[2][0]=16,ans.m[3][0]=8,ans.m[4][0]=4,ans.m[5][0]=2,ans.m[6][0]=1;
    n--;
    while(n){
        if(n&1) ans=mul(mat,ans);///顺序不能改变,矩阵乘法不满足交换侓。
        n>>=1;
        mat=mul(mat,mat);
    }
    return ans.m[0][0];
}

int main(){
    cin>>t;
    while(t--){
        cin>>n>>f1>>f2;
        init();
        cout<<slove()<<endl;
    }
}

参考博客:

http://blog.csdn.net/spring371327/article/details/52973534


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值