HDU5950 Recursive sequence —— 矩阵快速幂

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5950


Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1345    Accepted Submission(s): 606


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.



题解:

典型的矩阵快速幂的运用。关键是i^4怎么维护?我们可以当成求第i+1项,那么i^4就变成了(i+1)^4。那么这时我们可以用二项式定理从i^4、i^3、i^2、i^1、i^0的组合中得到(i+1)^4。也就是说总共需要维护:f[i+1]、f[i]、(i+1)^4、(i+1)^3、(i+1)^2、(i+1)^1、(i+1)^0。矩阵如下:






代码如下:

#include <bits/stdc++.h>
#define rep(i,s,t) for(int (i)=(s); (i)<=(t); (i)++)
#define ms(a,b) memset((a),(b),sizeof((a)))
using namespace std;
typedef long long LL;
const LL mod = 2147493647;
const int maxn = 1e5;

struct Mat
{
    LL mat[7][7];
    void init()
    {
        rep(i,0,6) rep(j,0,6)
            mat[i][j] = (i==j);
    }
};

Mat p = {   1, 2, 1, 4, 6, 4, 1,
            1, 0, 0, 0, 0, 0, 0,
            0, 0, 1, 4, 6, 4, 1,
            0, 0, 0, 1, 3, 3, 1,
            0, 0, 0, 0, 1, 2, 1,
            0, 0, 0, 0, 0, 1, 1,
            0, 0, 0, 0 ,0, 0, 1
        };

Mat mul(Mat x, Mat y)
{
    Mat s;
    ms(s.mat,0);
    rep(i,0,6) rep(j,0,6) rep(k,0,6)
        s.mat[i][j] += (x.mat[i][k]*y.mat[k][j])%mod, s.mat[i][j] %= mod;
    return s;
}

Mat qpow(Mat x, LL y)
{
    Mat s;
    s.init();
    while(y)
    {
        if(y&1)  s = mul(s, x);
        x = mul(x, x);
        y >>= 1;
    }
    return s;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        LL n, a, b;
        scanf("%lld%lld%lld",&n,&a,&b);
        if(n == 1)
        {
            printf("%lld\n",a);
            continue;
        }
        if(n == 2)
        {
            printf("%lld\n",b);
            continue;
        }

        Mat x = p;
        x = qpow(x, n-2);

        LL ans = 0;
        ans = (ans + b*x.mat[0][0]) % mod;
        ans = (ans + a*x.mat[0][1]%mod) % mod;
        ans = (ans + 16*x.mat[0][2]%mod) % mod;
        ans = (ans + 8*x.mat[0][3]%mod) % mod;
        ans = (ans + 4*x.mat[0][4]%mod) % mod;
        ans = (ans + 2*x.mat[0][5]%mod) % mod;
        ans = (ans+x.mat[0][6]) % mod;
        printf("%lld\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值