HDU 5950 Recursive sequence (矩阵快速幂)

78 篇文章 0 订阅
77 篇文章 8 订阅

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4283    Accepted Submission(s): 1852


Problem Description

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i^4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 

Input

The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 2^31 as described above.

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

Sample Input

2
3 1 2
4 1 10

Sample Output

85
369

Hint

In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

Source

2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5950

题目大意:给f[1],f[2]和递推式f[i]=2*f[i-2]+f[i-1]+i^4,求f[n]

题目分析: 看到数据范围和递推式第一反应就是矩阵快速幂,f数组好办,i^4转移需先将(i+1)^4展开

(i+1)^4=i^4+4i^3+6i^2+4i+1,需要维护一个7*7的转移矩阵transation

(1,1,0,0,0,0,0)

(2,0,0,0,0,0,0)

(1,0,1,0,0,0,0)

(4,0,4,1,0,0,0)

(6,0,6,3,1,0,0)

(4,0,4,3,2,1,0)

(1,0,1,1,1,1,1)

(f[i],f[i-1],i^4,i^3,i^2,i,1)* transation =(f[i+1],f[i],(i+1)^4,(i+1)^3,(i+1)^2,i+1,1)

#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const N = 7;
ll const MOD = 2147493647;
 
ll n, a, b;
 
struct matrix {
    ll mat[N][N];
    matrix() {
        memset(mat, 0, sizeof(mat));
    }
};
    
matrix mmul(matrix a, matrix b) {
    matrix ans;
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < N; j++) {
            if (a.mat[i][j]) {
                for (int k = 0; k < N; k++) {
                    ans.mat[i][k] += (a.mat[i][j] * b.mat[j][k]) % MOD;
                    ans.mat[i][k] %= MOD;
                }
            }
        }
    }
    return ans;
}
 
matrix mqpow(matrix a, ll n) {
    matrix ans;
    for (int i = 0; i < N; i++) {
        ans.mat[i][i] = 1;
    }
    while (n) {
        if (n & 1) {
            ans = mmul(ans, a);
        }
        a = mmul(a, a);
        n >>= 1;
    }
    return ans;
}
 
int main() {
    int T;
    scanf("%d", &T);
    matrix x;
    while (T--) {
        ll n, a, b;
        scanf("%lld %lld %lld", &n, &a, &b);
        if (n == 1) {
            printf("%lld\n", a % MOD);
            continue;
        }
        if (n == 2) {
            printf("%lld\n", b % MOD);
            continue;
        }
        memset(x.mat, 0, sizeof(x.mat));
        x.mat[0][0] = 1; x.mat[0][1] = 1;
        x.mat[1][0] = 2;
        x.mat[2][0] = 1; x.mat[2][2] = 1;
        x.mat[3][0] = 4; x.mat[3][2] = 4; x.mat[3][3] = 1;
        x.mat[4][0] = 6; x.mat[4][2] = 6; x.mat[4][3] = 3; x.mat[4][4] = 1;
        x.mat[5][0] = 4; x.mat[5][2] = 4; x.mat[5][3] = 3; x.mat[5][4] = 2; x.mat[5][5] = 1;
        x.mat[6][0] = 1; x.mat[6][2] = 1; x.mat[6][3] = 1; x.mat[6][4] = 1; x.mat[6][5] = 1; x.mat[6][6] = 1;
        x = mqpow(x, n - 2);
        ll init[7] = {b, a, 16, 8 ,4, 2, 1};
        ll ans = 0;
        for (int i = 0; i < N; i++) {
            ans = ans + init[i] * x.mat[i][0];
            ans %= MOD;
        }
        printf("%lld\n", ans);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值