uva 10168 Summation of Four Primes(数论-哥德巴赫猜想)

Problem A

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

 

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

 

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

 

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

 

Sample Input:

24
36
46

 

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7


Shahriar Manzoor

“You can fool some people all the time, all the people some of the

time but you cannot fool all the people all the time.”


题目大意:

给定一个数n,问你是否能用4个质因素相加表示,输出一种方案。


解题思路:

(1)如果n<8,很明显无答案。

(2)如果n>=8,结论是有答案。

因为按照哥德巴赫猜想,一个偶数可以用两个质因素相加表示。

那么,toyking猜想,一个数可以用4个质因素相加表示。

1. n为奇数,可以 用 2+3+偶数表示,偶数可以拆为两个质因素,枚举其中一个即可。

2. n为偶数,可以 用 2+2+偶数表示,偶数可以拆为两个质因素,枚举其中一个即可。


解题代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
using namespace std;

typedef long long ll;
const int maxn=10000010;
bool isPrime[maxn];
vector <int> v;
int tol;

void get_prime(){
    memset(isPrime,true,sizeof(isPrime));
    for(ll i=2;i<maxn;i++){
        if(isPrime[i]){
            tol++;
            v.push_back(i);
        }
        for(ll j=0;j<tol && i*v[j]<maxn;j++){
            isPrime[i*v[j]]=false;
            if(i%v[j]==0) break;
        }
    }
}

int main(){
    get_prime();
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n<8){
            printf("Impossible.\n");
            continue;
        }
        if(n&1){
            printf("2 3");
            n-=5;
        }
        else{
            printf("2 2");
            n-=4;
        }
        for(int i=0;i<tol && v[i]<=n;i++){
            if(isPrime[v[i]] && isPrime[n-v[i]]){
                printf(" %d %d\n",v[i],n-v[i]);
                break;
            }
        }
    }
    return 0;
}


转载于:https://www.cnblogs.com/toyking/p/3893154.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值