The Designer (笛卡尔定理+韦达定理 || 圆的反演)

Nowadays, little haha got a problem from his teacher.His teacher wants to design a big logo for the campus with some circles tangent with each other. And now, here comes the problem. The teacher want to draw the logo on a big plane. You could see the example of the graph in the Figure1



At first, haha's teacher gives him two big circles, which are tangent with each other. And, then, he wants to add more small circles in the area where is outside of the small circle, but on the other hand, inside the bigger one (you may understand this easily if you look carefully at the Figure1.

Each small circles are added by the following principles.
* you should add the small circles in the order like Figure1.
* every time you add a small circle, you should make sure that it is tangented with the other circles (2 or 3 circles) like Figure1.
    
The teacher wants to know the total amount of pigment he would use when he creates his master piece.haha doesn't know how to answer the question, so he comes to you.

Task


The teacher would give you the number of small circles he want to add in the figure. You are supposed to write a program to calculate the total area of all the small circles.
InputThe first line contains a integer t(1t1200), which means the number of the test cases. For each test case, the first line insist of two integers R1 and R2 separated by a space (1R100), which are the radius of the two big circles. You could assume that the two circles are internally tangented. The second line have a simple integer N (1N10 000 000), which is the number of small circles the teacher want to add.
OutputFor each test case:
Contains a number in a single line, which shows the total area of the small circles. You should out put your answer with exactly 5 digits after the decimal point (NO SPJ).
Sample Input
2
5 4
1
4 5
1
Sample Output
3.14159
3.14159
笛卡尔定理

 

若平面上四个半径为r 1、r 2、r 3、r 4的圆两两相切于不同点,则其半径满足以下结论:

 

(1)若四圆两两外切,则

 

(2)若半径为r 1、r 2、r 3的圆内切于半径为r 4的圆中,则
。    -------百度百科
 
韦达定理
 
设一元二次方程
中,两根x₁、x₂有如下关系:
 
-------百度百科
 
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
typedef long long ll;
const double eps = 1e-14;
const double PI = acos(-1.0);

void Debug()
{
    puts("");
    cout<<"+++++++++++++++++++++++++++分界线++++++++++++++++++++++++++++++"<<endl;
    for(int i=0; i<1; i++)
    {
        for(int j=0; j<1; j++)
        {
            cout<<13221321321312321<<" ";
        }
        cout<<endl;
    }
    cout<<"+++++++++++++++++++++++++++分界线++++++++++++++++++++++++++++++"<<endl;
    puts("");
}

int n;
double r1, r2, r3,r4;
double ans;
void sovel()
{
    if(r1 < r2) swap(r1,r2);
    r3 = r1-r2;
    double k1 = -1.0/r1, k2 = 1.0/r2, k3 = 1.0/r3, k4 = k1+k2+k3;
    ans = r3*r3;
    for(int i = 2; i <= n; i++)
    {
        r4 = 1.0/k4;
        ans += r4*r4;
        if(r4*r4 < eps)  break;
        if(i+1 <= n) ans +=r4*r4, i++;
        double k5 = 2*(k1+k2+k4) - k3;
        k3 = k4;
        k4 = k5;
    }
    printf("%.5f\n", ans*PI);

}

int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    int T;
    cin >> T;
    while(T--)
    {
        cin >> r1 >>r2 >> n;
        sovel();

    }
    return 0;
}

圆的反演 :

http://www.cnblogs.com/flipped/p/7397942.html


 

转载于:https://www.cnblogs.com/mrh-acmer/p/9515345.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值