POJ 1200 Crazy Search

Crazy Search
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20305 Accepted: 5751

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5
题目大意:有一个字符串总共包含NC种字符,求其长度为N的子串(不包含重复的)的数量。
解题思路:将子串转换为N位的NC进制数,然后通过哈希表统计出现次数。
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int hash_ch[257] = {0};
int hash_sum[16000001] = {0};
char str[16000001];

int main()
{
    int N, NC;
    int nCount = 0;
    int ans = 0;
    scanf("%d%d", &N, &NC);
    scanf("%s", str);
    int nlen = strlen(str);
    for (int i = 0; i < nlen; i++)
    {
        if (hash_ch[str[i]] == 0)
        {
            hash_ch[str[i]] = ++nCount;
        }
        if (nCount == NC)
        {
            break;
        }
    }
    for (int i = 0; i < nlen - N + 1; i++)
    {
        int sum = 0;
        int s = 0;
        for (int j = i; j < i + N; j++)
        {
            sum = sum * NC + hash_ch[str[j]];
        }
        if (hash_sum[sum] == 0)
        {
            hash_sum[sum] = 1;
            ans++;
        }
    }
    printf("%d\n", ans);
    return 0;
}

 

转载于:https://www.cnblogs.com/lzmfywz/p/3161199.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值