POJ1200 A - Crazy Search(哈希)

A - Crazy Search

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.
 
  题意:给出两个数n,nc,并给出一个由nc种字符组成的字符串。求这个字符串中长度为n的子串有多少种。
  先将每个不同字母转化为一个数。再根据此将每一个字串转化为一个数,存入hash表里。存的方法是:每一个字串是一个连续的数,nc(不同字母数)作用就在这里。把这串连续的数转化为nc进制数,然后判断存在就可以了.
  
#include<iostream>          
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const int maxn=16000005;
ll hash[maxn],num[29];
char s[maxn];
int main()
{
    ll n,m;
    while(~scanf("%lld%lld%s",&n,&m,s))
    {
    //    memset(hash,0,sizeof(hash));
    //    memset(num,0,sizeof(num));
        ll len=strlen(s);
        ll cnt=0;
        num[s[0]]=cnt++;
        for(int i=1;i<len;i++)
        {
            if(num[s[i]]==0)
                num[s[i]]=cnt++;
        }    
        ll ans=0;
        for(int i=0;i<=len-n;i++)
        {
            ll sum=0;
            for(int j=0;j<n;j++)
            {
                sum=sum*m+num[s[i+j]];
            //    printf("%lld * %lld+%lld     ",sum,m,num[s[i+j]]);
            }
            if(!hash[sum])
            {
                ans++;
        //        printf("hash[sum]:%lld  sum:%lld \n",hash[sum],sum);
                hash[sum]=1;
            }
        }
        printf("%lld\n",ans);
    }    
    return 0;
}

 

  

转载于:https://www.cnblogs.com/liyexin/p/11574718.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值