[BestCoder Round #3] hdu 4908 BestCoder Sequence (计数)

BestCoder Sequence



Problem Description
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as  Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are  bestcoder sequences in a given permutation of 1 ~ N.
 

Input
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 

Output
For each case, you should output the number of consecutive sub-sequences which are the  Bestcoder Sequences
 

Sample Input
 
   
1 1 1 5 3 4 5 3 2 1
 

Sample Output
 
   
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.
 

Source


解题思路:

题意为 给定一个1 -N的排列,再给定一个数M(1<=M<=N)。问有多少连续的长度为奇数子序列,使得M在当中为中位数(M在子序列中)。

比方例子

5 3

4 5 3 2 1 N=5, M=3

{3},{5,3,2},{4,5,3,2,1} 为符合题意的连续子序列....

当时做的时候把包括M的全部长度为0,1,2.......的连续子序列都枚举了出来。然后推断推断M是否是中位数。结果 果断超时.......

贴一下题解思路:




写了一堆字,CSDN的排版太....了,贴图片把.


代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=40010;
int sum[maxn];
int cnt[maxn*2];
int n,m;
int val,p;

int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            sum[i]=sum[i-1];
            scanf("%d",&val);
            if(val<m)
                sum[i]--;
            else if(val>m)
                sum[i]++;
            else
                p=i;
        }
        memset(cnt,0,sizeof(cnt));
        for(int i=0;i<p;i++)
            cnt[sum[i]+maxn]++;
        int ans=0;
        for(int i=p;i<=n;i++)
            ans+=cnt[sum[i]+maxn];
        printf("%d\n",ans);
    }
    return 0;
}




转载于:https://www.cnblogs.com/yfceshi/p/6797306.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值