Power Strings POJ - 2406 (KMP)

                                                                                                               

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
 
分析: 题目求字符串的最小循环节,可以利用KMP的next数组性质
next[len]表示字符串前缀和后缀的最大公共长度。
比如长度为8的字符串 abababab   next[len]=6 即最长公共长度为6
进而推出最小循环节即为2
代码如下
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 1000002;
int next[N];
char S[N], T[N];
int slen, tlen;

void getNext()
{
    int j, k;
    j = 0; k = -1; next[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
            next[++j] = ++k;
        else
            k = next[k];

}
int main()
{

    int TT;
    int i, cc,ans;
    while(scanf("%s",T)!=EOF)
    {
        if(T[0]=='.')
            break;
       tlen=strlen(T);
        getNext();
        ans=tlen-next[tlen];
        if(tlen%ans==0)
        printf("%d\n",tlen/ans);
        else
        printf("1\n");
    }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/a249189046/p/7374330.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值