Power Strings(POJ-2406)

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:每组数据给出一个字符串,要求输出这个字符串的循环节,输入以 . 为结束标记

思路:KMP 求循环节个数模版题

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-9
#define INF 0x3f3f3f3f
#define N 1000001
#define LL long long
const int MOD=20091226;
const int dx[]= {-1,1,0,0};
const int dy[]= {0,0,-1,1};
using namespace std;
int next[N];
char p[N];
void getNext(){
    next[0]=-1;

    int len=strlen(p);
    int j=0;
    int k=-1;

    while(j<len) {
        if(k==-1||p[j]==p[k]) {
            k++;
            j++;
            if(p[j]==p[k])
                next[j]=next[k];
            else
                next[j]=k;
        }else{
            k=next[k];
        }
    }
}
int main(){

    while(scanf("%s",p)!=EOF){
        memset(next,0,sizeof(next));
        if(p[0]=='.')
            break;

        int n=strlen(p);
        getNext();

        int len=n-next[n];
        if(n%len==0)
            printf("%d\n",n/len);
        else
            printf("1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值