Fractal
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 11143 | Accepted: 4988 |
Description
A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
Your task is to draw a box fractal of degree n.
A box fractal is defined as below :
- A box fractal of degree 1 is simply
X - A box fractal of degree 2 is
X X
X
X X - If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
B(n - 1) B(n - 1) B(n - 1) B(n - 1) B(n - 1)
Your task is to draw a box fractal of degree n.
Input
The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.
Output
For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.
Sample Input
1 2 3 4 -1
Sample Output
X - X X X X X - X X X X X X X X X X X X X X X X X X X X X X X X X - X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X X -
Source
先说明下借鉴了zyh的题解:https://blog.csdn.net/wyt734933289/article/details/47132959
做这道画图题的同时,体现出我对递归理解的缺失,还是要补一补。
和dfs有些相像,毕竟也是通过递归调用调整自己要用到的位置并改变该位置的符号为“X”。只是这个位置的改变是通过有比例的多方向的位置改变。
而这道题的比例则是可以看出是3。
看别人的题解是通过左上变化的,我就用下中间的X吧,虽然区别不大。
控制比例我就用f1()函数写了:
int f1(int t) {
int hh = 1;
for(int i = 0; i < t-1; i++) {
hh *= 3;
}
return hh;
}
标记函数dfs():
void dfs(int d, int x, int y) {
if(d == 1) {
arr[x][y] = 'X';
return ;
} else {
int h = f1(d-1);
dfs(d-1, x, y);
dfs(d-1, x-h, y-h);
dfs(d-1, x-h, y+h);
dfs(d-1, x+h, y-h);
dfs(d-1, x+h, y+h);
}
}
主函数中先把字符型二维数组初始化为空格
下面是我的ac代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
char arr[1000][1000];
int f1(int t) {
int hh = 1;
for(int i = 0; i < t-1; i++) {
hh *= 3;
}
return hh;
}
void dfs(int d, int x, int y) {
if(d == 1) {
arr[x][y] = 'X';
return ;
} else {
int h = f1(d-1);
dfs(d-1, x, y);
dfs(d-1, x-h, y-h);
dfs(d-1, x-h, y+h);
dfs(d-1, x+h, y-h);
dfs(d-1, x+h, y+h);
}
}
int main() {
int t;
while(scanf("%d", &t) != EOF) {
if(t == -1) break;
memset(arr, ' ', sizeof(arr));
int m, n;
m = n = f1(t)/2;
dfs(t, m, n);
for(int i = 0; i < f1(t); i++) {
arr[i][f1(t)] = '\0';
}
for(int i = 0; i < f1(t); i++) {
puts(arr[i]);
}
puts("-");
}
return 0;
}