POJ - 2431 Expedition(贪心+优先队列)

点击打开题目链接

Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15297 Accepted: 4281

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

人一我百,人十我万!追逐青春的梦想,怀着自信的心,永不放弃!教主最帅!!!(=。=!显然最后一句并非原话)今天集训的时候教主投到公屏上的kuangbin大神励志,本弱猪发到这里,共勉一下。

回到题目:一辆卡车从A点到B点,中间有N个加油站,每个加油站加油量不等,求使得卡车到达目的地的最小加油次数。

还是贪心问题,这里只需要加一个优先队列,把中途的加油站加油量存进去,当卡车没油的时候取队列里的最大油量,记录取油的次数即可。为了便于计算,可将题目中到终点的距离改为到出发点的距离,终点看作加油量为0的加油站。

附上AC代码:(T~T困死了,想睡觉!!!)

#include<bits/stdc++.h>

using namespace std;
const int maxn=10000+5;
int n,l,p;//l剩余油,p剩余距离

struct stop{
    int x,y;
}s[maxn];
bool cmp(stop s1,stop s2 )
{
    return s1.x<s2.x;
}

int main()
{

    cin>>n;
    for(int i=0;i<n;i++)
        cin>>s[i].x>>s[i].y;

    cin>>l>>p;
    for(int i=0;i<n;i++)
        s[i].x=l-s[i].x;
    s[n].x=l;
    s[n].y=0;
    n++;
    sort(s,s+n,cmp);

    priority_queue<int> pq;
    int ans=0,tank=p,pos=0;
   for(int i=0;i<n;i++)
    {
        int d=s[i].x-pos;
        while(tank-d<0)
        {
            if(pq.empty())
            {
                puts("-1");
            return 0;
            }
              tank+=pq.top();
              pq.pop();
              ans++;
        }
        tank-=d;
        pos=s[i].x;
        pq.push(s[i].y);
    }
    cout<<ans<<endl;
    return 0;
}


转载于:https://www.cnblogs.com/l1832876815/p/6771173.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值