Number Transformation

Description

 In this problem, you are given a pair of integers A and B. You can transform any integer number A to B by adding x to A.This x is an integer number which is a prime below A.Now,your task is to find the minimum number of transformation required to transform S to another integer number T.

Input

 Input contains multiple test cases.Each test case contains a pair of integers S and T(0< S < T <= 1000) , one pair of integers per line. 

Output

 For each pair of input integers S and T you should output the minimum number of transformation needed as Sample output in one line. If it's impossible ,then print 'No path!' without the quotes.

Sample Input

5
7
3
4

Sample Output

Need 1 step(s)
No path!
//从A->B能转化的要求是存在一个质数x,使得x<A ,而且A+x == B 。
//首先我们可以用线性筛素法筛出所有的素数,然后就是bfs搜索就可以了。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN = 1050 ;

struct Node
{
    int num ,d ;
    Node() {};
    Node(int a, int b):num(a),d(b) {}
};
bool prim[MAXN] ;
bool mark[MAXN] ;
int C , S ,T ;

void isprim()
{
    for(int i = 2 ; i < MAXN ; i ++)
        prim[i] = 1 ;
    for(int i = 2 ; i < MAXN ; i ++)
        if(prim[i])
            for(int j = 2 ; i * j < MAXN ; j ++)
                prim[i * j] = 0 ;
}

int bfs(int source , int destation)
{
    queue<Node> Q ;
    memset(mark , 0 , sizeof(mark)) ;
    Node a ;
    Q.push( Node(source , 0) )  ;
    mark[source] = 1 ;
    while( !Q.empty() )
    {
        a = Q.front() ;
        Q.pop() ;
        //搜索比它小的素数
        for(int i = 2 ; i < a.num ; i ++)
        {
            //判断要加的数是不是素数
            if(!prim[i] )continue ;

            int number = a.num + i ;
            //大于所要求的目标数,直接退出
            if(number > destation) break ;
            if(mark[number]) continue ;

            mark[number] = 1 ;
            if(number == destation)
                return a.d + 1;
            Q.push( Node(number , a.d+1) ) ;
        }
    }
    return -1 ;
}

int main()
{
    isprim() ;
    while( scanf("%d%d" , &S , &T) == 2 )
    {
        int d = bfs(S , T) ;
        if(d==-1) printf("No path!\n") ;
        else      printf("Need %d step(s)\n" , d) ;
    }
    return 0 ;
}
BFS

 

转载于:https://www.cnblogs.com/contestant/p/3306148.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值