hdu 3706 Second My Problem First 单调队列

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3706

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



Problem Description
Give you three integers n, A and B. 
Then we define S i = A i mod B and T i = Min{ S k | i-A <= k <= i, k >= 1}
Your task is to calculate the product of T i (1 <= i <= n) mod B.
 

 

Input
Each line will contain three integers n(1 <= n <= 10 7),A and B(1 <= A, B <= 2 31-1). 
Process to end of file.
 

 

Output
For each case, output the answer in a single line.
 

 

Sample Input
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

 

Sample Output
2 3 4 5 6
 

 

Author
WhereIsHeroFrom@HDU
 

 

Source
 
单调队列简单题;
卡内存,list过不了,deque,G++过的;
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
#define bug(x)  cout<<"bug"<<x<<endl;
const int N=1e7+10,M=4e6+10,inf=2147483647;
const ll INF=1e18+10,mod=1e9+7;
///   数组大小
int d[N];
ll num[N];
int main()
{
    ll n,a,b;
    while(~scanf("%lld%lld%lld",&n,&a,&b))
    {
        ll ans=1,base=a%b;
        int s=0,e=0;
        for(int i=1;i<=n;i++,base=(base*a)%b)
        {
            num[i]=base;
            while(s<e&&d[s]<i-a)s++;
            while(e>s&&num[d[e]]>=num[i])e--;
            d[++e]=i;
            //cout<<num[d[s+1]]<<" "<<endl;
            ans=ans*(num[d[s+1]])%b;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/jhz033/p/6666204.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值