hdu 1099 Lottery

这是我第一次写博客,作为一个ACMer,经常进别人的博客,所以自己也想写写博客。

HDU 1099

Lottery

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2648    Accepted Submission(s): 1191


Problem Description
Eddy's company publishes a kind of lottery.This set of lottery which are numbered 1 to n, and a set of one of each is required for a prize .With one number per lottery, how many lottery on average are required to make a complete set of n coupons?
 

 

Input
Input consists of a sequence of lines each containing a single positive integer n, 1<=n<=22, giving the size of the set of coupons.
 

 

Output
For each input line, output the average number of lottery required to collect the complete set of n coupons. If the answer is an integer number, output the number. If the answer is not integer, then output the integer part of the answer followed by a space and then by the proper fraction in the format shown below. The fractional part should be irreducible. There should be no trailing spaces in any line of ouput.
 

 

Sample Input
2 5 17
 

 

Sample Output
3 5 11 -- 12 340463 58 ------ 720720

 
题目的大概意思是说一套彩票有编号1到n共n种,张数不限,问你平均买多少张能把编号为1到n的n中彩票全买下来,也就是求期望。
举个例子,当n=5时,第一张有用的概率为1,买一张就行了,第二张有用的概率为4/5,所以买5/4张彩票能买上对你有用的,一次类推,sum=1+5/4+5/3+5/2+5/1=11…5/12,再有就是注意格式
附上我的AC代码
#include <iostream>
using namespace std;

int n,s,a1,b1,a2,b2,s1,s2;
int gcd(int x,int y)
{
    int t;
    while (x%y!=0)
    {
          t=x%y;
          x=y;
          y=t;
    }
    return y;
}
int f(int x,int y)
{
    int t1=a1,t2=b1;
    a1=t1*y+b1*x;
    b1=t2*y;
    int t=a1/b1;
    s+=t;
    a1-=t*b1;
    t=gcd(a1,b1);
    a1=a1/t;
    b1=b1/t;
}
int main()
{
    while (cin>>n)
    {
          s=0;
          a1=0;b1=1;
          for (int i=1;i<=n;i++)
          {
              f(n,i);
          }
          if (a1==0)
          cout <<s<<endl;//" "<<a1<<" "<<b1<<endl;
          else
          {
              int t1=0,t2=0,temp1=s,temp2=b1;
              while (temp1!=0)
              {
                  t1++;
                  temp1/=10;
              }
              t1++;
              while (temp2!=0)
              {
                  t2++;
                  temp2/=10;
              }
              for (int i=1;i<=t1;i++)
              cout <<" ";
              cout <<a1<<endl;
              cout <<s<<" ";
              for (int i=t2;i>=1;i--)
              cout <<"-";
              cout <<endl;
              for (int i=1;i<=t1;i++)
              cout <<" ";
              cout <<b1<<endl;
          }   
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/arno-my-boke/p/4238137.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值