poj-1164 The Castle

     1   2   3   4   5   6   7  

#############################
1 # | # | # | | #
#####---#####---#---#####---#
2 # # | # # # # #
#---#####---#####---#####---#
3 # | | # # # # #
#---#########---#####---#---#
4 # # | | | | # #
#############################
(Figure 1)

# = Wall
| = No wall
- = No wall

Figure 1 shows the map of a castle.Write a program that calculates 
1. how many rooms the castle has 
2. how big the largest room is 
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

Input

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

这题的题面很长,大致意思是每个坐标有东南西北四个方位,每个方位都可能有墙。1,2,4,8分别是西,北,东,南
四个方位有墙,输入的每位数字是墙的标号之和,比如11是1+2+8,就是西,北,南有墙,要求算的是有多少个连通块
和最大连通块连了几个坐标。
这四个数字很特殊,没错,就是用二进制的位运算判断。
附代码:
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int M = 55;
int map[M][M];
int vis[M][M];
int n,m,maxx=0,cnt=0,res=0;
void dfs(int x,int y){
    
    if((y-1)>=1&&!(map[x][y]&1)&&!vis[x][y-1]){
     //   cout<<1<<endl;
        vis[x][y-1]=1;
        cnt++;
        dfs(x,y-1);
    }
    if((x-1)>=1&&!(map[x][y]&2)&&!vis[x-1][y]){
     //   cout<<2<<endl;
        vis[x-1][y]=1;
        cnt++;
        dfs(x-1,y);
    }
    if((y+1)<=m&&!(map[x][y]&4)&&!vis[x][y+1]){
     //   cout<<3<<endl;
        vis[x][y+1]=1;
        cnt++;
        dfs(x,y+1);
    }
    if((x+1)<=n&&!(map[x][y]&8)&&!vis[x+1][y]){
     //   cout<<4<<endl;
        vis[x+1][y]=1;
        cnt++;
        dfs(x+1,y);
    }
}
int main(){
    while(cin>>n>>m){
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                cin>>map[i][j];
            }
        }
        maxx=0;res=0;cnt=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(!vis[i][j]){
                    if(map[i][j]!=15)
                    {
            //        cout<<i<<" "<<j<<endl;
                    vis[i][j]=1;
                    dfs(i,j);
                    
                    maxx=max(cnt,maxx);
                  //  cout<<cnt<<" maxx"<<endl;
                    cnt=1;
                    }
                    res++;
                }
            }
        }
        cout<<res<<endl<<maxx<<endl;
    }
    return 0;
}

  




转载于:https://www.cnblogs.com/zmin/p/7340151.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值