POJ-1164-城堡问题

1.描述

在这里插入图片描述

在这里插入图片描述

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls.

Input
Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output
Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).
Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13
Sample Output
5
9

2.解题思路

  • 把方块看成节点,相邻两个方块之间如果没有墙,则在方块之间连城一条边,这样城堡就能转换成一个图
  • 求房间个数,实际上就是在求图中有多少个极大连通子图
  • 一个连通子图,往里面加任何一个图里的其他点,就会变得不连通,那么这个连通子图就是极大连通子图
  • 在这里插入图片描述

3.代码

public class Main {
    public static void main(String[] args) {
        InputStream inputStream = System.in;
        OutputStream outputStream = System.out;
        Scanner in = new Scanner(inputStream);
        PrintWriter out = new PrintWriter(outputStream);
        Poj1164 solver = new Poj1164();
        solver.solve(1, in, out);
        out.close();
    }

    static class Poj1164 {
        int r;
        int c;
        int[][] g = new int[55][55];
        boolean[][] flag = new boolean[55][55];
        int maxArea = 0;
        int areaNum;

        public void solve(int testNumber, Scanner in, PrintWriter out) {
            r = in.nextInt();
            c = in.nextInt();
            for (int i = 1; i <= r; i++)
                for (int j = 1; j <= c; j++)
                    g[i][j] = in.nextInt();
            int castleNum = 0;
            for (int i = 1; i <= r; i++) {
                for (int j = 1; j <= c; j++) {
                    if (flag[i][j] == false) {
                        castleNum++;
                        areaNum = 0;
                        dfs(i, j);
                        maxArea = Math.max(maxArea, areaNum);
                    }
                }
            }
            out.println(castleNum);
            out.println(maxArea);
        }

        private void dfs(int i, int j) {
            if (i > r || j > c || i < 0 || j < 0)
                return;
            if (flag[i][j] == true)
                return;
            areaNum++;
            flag[i][j] = true;
            //西边没有墙
            if ((g[i][j] & 1) == 0)
                dfs(i, j - 1);
            //北边没有墙
            if ((g[i][j] & 2) == 0)
                dfs(i - 1, j);
            //东边没有墙
            if ((g[i][j] & 4) == 0)
                dfs(i, j + 1);
            //南边没有墙
            if ((g[i][j] & 8) == 0)
                dfs(i + 1, j);
        }

    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值