POJ - 1164 The Castle(图论/DFS 迷宫问题)

5 篇文章 0 订阅

问题描述

     1   2   3   4   5   6   7  

   #############################

 1 #   |   #   |   #   |   |   #

   #####---#####---#---#####---#

 2 #   #   |   #   #   #   #   #

   #---#####---#####---#####---#

 3 #   |   |   #   #   #   #   #

   #---#########---#####---#---#

 4 #   #   |   |   |   |   #   #

   #############################

            (Figure 1)

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls.
Input
Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output
Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

分析:

这题呵呵。我就是蠢,刚开始看题,哦,就是迷宫啊,没啥难度,咦,不对,它输入的是一些数字,咋建图,然后自以为通过数字然后建一个原来经常做的迷宫图,建个鬼啊,还花了半小时研究咋建QAQ。

哦,后来发现直接通过输入的数字DFS,我起初这样的。

if(map[x][y] == 1 || map[x][y] == 4 || map[x][y] == 5 || map[x][y] == 8 || map[x][y] == 9 || map[x][y] == 12 || map[x][y] == 13)
    {
        if(used[x-1][y] == false && x-1 >= 0 && y >= 0 && x-1 < n && y < m)
        {
            k++;
            used[x-1][y] = true;
            dfs(x-1, y,k);
        }
    }

额,这是向上走的情况,向下左右就不写了
怎么提交都是wa,然后找了一遍又一遍以为是情况少了,因为就1到15这15个数字,除了15四面都是被墙封起来的,其他数都是有可以走的方向,所以我就一个个列情况,可是就是wa,后来实在不行,直接参考别人的位与了,直接a了,很气啊,调试了一下,发现位与和我的直接枚举没有差别,偏偏wa,不知道到底哪里有问题。


代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 50+10;
int map[maxn][maxn];
bool used[maxn][maxn];
int n,m;

void dfs(int x, int y, int &k)
{
    if((map[x][y] & 2) == 0)
    {
        if(used[x-1][y] == false && x-1 >= 0 && y >= 0 && x-1 < n && y < m)
        {
            k++;
            used[x-1][y] = true;
            dfs(x-1, y,k);
        }
    }
    if((map[x][y] & 8) == 0)
    {
        if(used[x+1][y] == false && x+1 >= 0 && y >= 0 && x+1 < n && y < m)
        {
            k++;
            used[x+1][y] = true;
            dfs(x+1, y, k);
        }
    }
    if((map[x][y] & 1) == 0)
    {

        if(used[x][y-1] == false && x >= 0 && y-1 >= 0 && x < n && y-1 < m)
        { 
            k++;
            used[x][y-1] = true;
            dfs(x, y-1, k);
        }
    }
    if((map[x][y] & 4) == 0)
    {

        if(used[x][y+1] == false && x >= 0 && y+1 >= 0 && x < n && y+1 < m)
        {
            k++;
            used[x][y+1] = true;
            dfs(x, y+1, k);
        }
    }
    return;
}

int main()
{
    scanf("%d%d",&n, &m);
    int r;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
        {
            scanf("%d",&map[i][j]);
            used[i][j] = false;
        }
    }
    int count = 0;
    int max_a = 0;
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<m; j++)
        {
            if(used[i][j] == false)
            {
                used[i][j] = true;
                int k = 1;
                dfs(i, j, k);
                max_a = max(max_a, k);
                count ++;
            }   
        }   
    }   
    printf("%d\n%d\n",count, max_a);
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值