POJ1164--The Castle

3 篇文章 0 订阅

Description

     1   2   3   4   5   6   7  

   #############################

 1 #   |   #   |   #   |   |   #

   #####---#####---#---#####---#

 2 #   #   |   #   #   #   #   #

   #---#####---#####---#####---#

 3 #   |   |   #   #   #   #   #

   #---#########---#####---#---#

 4 #   #   |   |   |   |   #   #

   #############################

(Figure 1)



#  = Wall   

|  = No wall

-  = No wall

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls.
Input
Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.
Output
Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).
Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9

这道题是老师布置的宽搜作业,然后我就用宽搜写了,写完了才发现用深搜好像也可以。。。
做宽搜好像有点感觉了。。。但是还是被这道简单题卡了一个多小时。。。
遇到的坑首先有打的表后来才发现表现“1”的地方是在最后一位,一开始一直把第一位当成“1”那位,就很尴尬地调了半天,然后后来发现是这道题的n代表的是水平方向的长,m代表竖直方向的。。。一直没反应过来,又颓了半个小时。。

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
int m,n;
int mx=0;
int cnt;
bool rom[55][55][10];
bool vis[55][55];
int num=0;
int dy[4]= {-1,0,1,0},dx[4]= {0,-1,0,1};
int wal[16][4]= {{0,0,0,0},{0,0,0,1},{0,0,1,0},{0,0,1,1},{0,1,0,0},{0,1,0,1},{0,1,1,0},{0,1,1,1},{1,0,0,0},{1,0,0,1},{1,0,1,0},{1,0,1,1},{1,1,0,0},{1,1,0,1},{1,1,1,0},{1,1,1,1}};//打的二进制的表。。。神坑(可能只有我一个人被坑)
int bfs(int a,int b) {
    if(vis[a][b])return 0;
    vis[a][b]=1;
    int hd=0,tl=1;
    int x[2505];
    num=1;
    int y[2505];
    memset(x,0,sizeof(x));
    memset(y,0,sizeof(y));
    x[++hd]=a;
    y[hd]=b;

    cnt++;
    while(hd<=tl) {
        for(int i=0; i<4; i++) {
            if(!vis[dx[i]+x[hd]][dy[i]+y[hd]]&&!rom[x[hd]][y[hd]][i]&&dx[i]+x[hd]>0&&dx[i]+x[hd]<=m&&dy[i]+y[hd]>0&&dy[i]+y[hd]<=n) {
                x[++tl]=dx[i]+x[hd];
                y[tl]=dy[i]+y[hd];
                vis[dx[i]+x[hd]][dy[i]+y[hd]]=1;
                num++;
            }
        }
        hd++;
    }
    num=tl;return 0;
}
int main() {
    scanf("%d%d",&m,&n);
    for(int i=1; i<=m; i++) {
        for(int j=1; j<=n; j++) {
            int a;
            scanf("%d",&a);
            if(wal[a][3]) {
                rom[i][j][0]=1;
            }
            if(wal[a][2]) {
                rom[i][j][1]=1;
            }
            if(wal[a][1]) {
                rom[i][j][2]=1;
            }
            if(wal[a][0]) {
                rom[i][j][3]=1;
            }
        }
    }
    for(int i=1; i<=m; i++)
        for(int j=1; j<=n; j++) {
            bfs(i,j);
            mx=max(num,mx);
        }
    cout<<cnt<<endl<<mx;return 0;
}

最后发现自己没有写cstdio的库,为poj交上了一份CE。。。难受

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值