hdu 1503 Advanced Fruits(LCS输出路径)

Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 
 

 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

 

Sample Input
apple peach
ananas banana
pear peach
 
Sample Output
appleach
bananas
pearch
 
题意:将两个字符串结合起来,他们的公共子串只输出一次
思路:LCS处理以后逆序输出  标记路径的方法值得学习,如果字母不相同的话就看 当前i和j谁能影响前面的公共字母个数 。
#include <cstdio>
#include <map>
#include <iostream>
#include<cstring>
#include<bits/stdc++.h>
#define ll long long int
#define M 6
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int dp[107][107];
int mark[107][107]; //0表示为公共字母  1表示i-1没有贡献  -1表示j-1没有贡献 
string s,t;
void output(int i,int j){ //打印路径 
//    cout<<i<<" "<<j<<endl;
    if(i==0||j==0){
        if(i==0)
            for(int k=0;k<j;k++)
                cout<<t[k];
        else
            for(int k=0;k<i;k++)
                cout<<s[k];
        return ;
    } 
    if(mark[i][j]==0){
        output(i-1,j-1);
        cout<<s[i-1];
    }else if(mark[i][j]==-1){
        output(i-1,j);
        cout<<s[i-1];
    }else{
        output(i,j-1);
        cout<<t[j-1];
    }
}
int main(){
    ios::sync_with_stdio(false);
    while(cin>>s>>t){
        memset(dp,0,sizeof(dp));
        memset(mark,0,sizeof(mark));
        int len1,len2;
        len1=s.length(); len2=t.length();
        for(int i=1;i<=len1;i++)
            for(int j=1;j<=len2;j++){
                if(s[i-1]==t[j-1]){  
                    dp[i][j]=dp[i-1][j-1]+1;
                    mark[i][j]=0;
                }else if(dp[i][j-1]>dp[i-1][j]){
                    dp[i][j]=dp[i][j-1];
                    mark[i][j]=1;
                }else{
                    dp[i][j]=dp[i-1][j];
                    mark[i][j]=-1;
                }
            }
        output(len1,len2);
        cout<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wmj6/p/10396297.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值