Advanced Fruits

     Advanced Fruits

 

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 

Input is terminated by end of file. 
Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable. 
Sample Input
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas
pearch

解题思路:
本题不难看出是LCS最长公共子序列的一个升级版,将两个序列不是最长公共子序列的部分都输出,是最长公共子序列的部分只输出一次。回顾我们在求LCS的时候的算法。
if(s1[i-1] == s2[j-1])f[i][j] = f[i-1][j-1] + 1;
else f[i][j] = max(f[i-1][j],f[i][j-1]);
我们发现当s1[i-1]和s2[j-1]相等的时候(这里序列下标从0开始),f[i][j] = f[i-1][j-1] + 1。只是在原来的长度上增加1。而不等的时候取一个最大值便可。
通过观察我们发现f[i][j]只能有三种状态转移而来f[i-1][j-1],f[i-1][j],f[i][j-1]。而f[i][j]每次更新的路径其实就是我们要求的那个合并后的序列,所以我们再用一个数组记录路径,最后用一个递归输出即可。
代码如下;
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 100 + 5;

char s1[maxn],s2[maxn];
int dp[maxn][maxn],p[maxn][maxn];

void print(int ls1,int ls2)
{
    if(ls1 == 0 && ls2 == 0)return;
    if(p[ls1][ls2] == 0)print(ls1-1,ls2-1),printf("%c",s1[ls1-1]);
    else if(p[ls1][ls2] == 1)print(ls1-1,ls2),printf("%c",s1[ls1-1]);
    else print(ls1,ls2-1),printf("%c",s2[ls2-1]);
}

int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        int ls1 = strlen(s1);
        int ls2 = strlen(s2);
        memset(dp,0,sizeof(dp));
        for(int i = 1;i <= ls1; i++)p[i][0] = 1;
        for(int j = 1;j <= ls2; j++)p[0][j] = -1;
        for(int i = 1;i <= ls1; i++)
        {
            for(int j = 1;j <= ls2; j++)
            {
                if(s1[i-1] == s2[j-1])dp[i][j] = dp[i-1][j-1] + 1,p[i][j] = 0;
                else if(dp[i-1][j] >= dp[i][j-1])dp[i][j] = dp[i-1][j],p[i][j] = 1;
                else dp[i][j] = dp[i][j-1],p[i][j] = -1;
            }
        }
        print(ls1,ls2);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值