hdu1503 Advanced Fruits

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2017    Accepted Submission(s): 1029
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch
嗯,题目大意就是说,两个序列,他们的最长公共子序列只打印一次,而其他字符不改变其原先的相对先后顺序
这里需要另一个二维数组进行标记当前公共子序列的下面一位非公共序列的字符取自s1还是s2.
<span style="font-size:14px;">//以下仅表示个人理解,有错误是难免的,希望看出来的同学能给予指正,谢谢~
#include<cstdio>
#include<cstring>
char s1[110],s2[110];
int dp[110][110],rec[110][110];
void dfs(int i,int j)
{
    if(!i&&!j)
        return ;
    if(rec[i][j]==0)
    {
        dfs(i-1,j-1);
        printf("%c",s1[i-1]);//因为此时是s1[i-1]==s2[j-1]所以这里都一样
    }
    else if(rec[i][j]==1)
    {
        dfs(i-1,j);
        printf("%c",s1[i-1]);//因为之前标记的,表示此时子序列后面的一位是s1的第i-1位,即输出
    }
    else
    {
        dfs(i,j-1);
        printf("%c",s2[j-1]);//表示此时子序列后面的一位是s2的第j-1位,即输出
    }
}
int main()
{
    int len1,len2;
    while(~scanf("%s%s",s1,s2))
    {
        len1=strlen(s1);
        len2=strlen(s2);
        for(int i=0;i<=len1;++i)//从极端情况考虑理解,表示若公共子序列在s1的前面s2的后面,则s2先输出完,子序列后面的自然是s1中字符
            rec[i][0]=1;
        for(int j=0;j<=len2;++j)//表示若公共子序列在s2的前面s1的后面,则s1先输出完,子序列后面的自然是s2中字符
            rec[0][j]=-1;
        for(int i=1;i<=len1;++i)//其实dp[i][j]记录的是s1从0到i与s2从0到j这两段序列的最长公共子序列的长度
        {
            for(int j=1;j<len2;++j)
            {
                if(s1[i-1]==s2[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    rec[i][j]=0;
                }
                else if(dp[i-1][j]>dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];//此时表示选择的是(s1的第i-2个字符的状态)也表示此时子序列的后面一位是s1的第i-1位字符
                    rec[i][j]=1;
                }
                else
                {
                    dp[i][j]=dp[i][j-1];//此时表示选择的是(s2的第j-2个字符的状态)也表示此时子序列的后面一位是s2的第j-1位字符
                    rec[i][j]=-1;
                }
            }
        }
        dfs(len1,len2);
    }
    return 0;
}
</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值