UVA 11827 Maximum GCD ( 暴力搜+GCD函数 )

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases. The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

 

直接暴力两个两个求LCM,取最大值!

麻烦是输入:用ungetc函数进行读取

#include <iostream>
#include <cstdio>
#include <cstdlib>

using namespace std;

int g[111];

int gcd(int a,int b){
    return b == 0 ? a : gcd(b,a%b);
}

int main()
{
    int _;scanf("%d",&_);
    while(getchar()!='\n');
    while(_--){
        int n=0;
        char ch;
        while((ch = getchar()) != '\n')
            if(ch>='0'&&ch<='9'){
                ungetc(ch,stdin);//这里将输入的数字字符进行退流,但遇到一个非数字时就输入到g数组中
                scanf("%d",&g[n++]);
            }
        int maxn=1;
        for(int i=0;i<n-1;i++)
            for(int j=i+1;j<n;j++)
                maxn = max(maxn,gcd(g[i],g[j]));
        printf("%d\n",maxn);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/BugClearlove/p/4703526.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值