【数论】Prime Time (strtok函数用法)

 

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases. The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25 

【题解】:

意思是在一组数里面找出一对最大的GCD。

暴力两个for即可,数论只会GCD。。。

然而我写这篇博客主要是因为;

strtok函数用法

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
typedef long long ll;
int gcd(int a,int b){
    return a%b==0?b:gcd(b,a%b);
}
int main()
{
    int T;
    scanf("%d",&T);
    getchar();
    char str[100005];
    while(T--){
        int a[1000],n=0;
        cin.getline(str,sizeof(str));
        //fgets(str,sizeof(str),stdin);
        char tt[]=" ";
        char *ptr;
        ptr=strtok(str,tt);
        while(ptr!=NULL){
            sscanf(ptr,"%d",&a[n++]);
            //printf("%s\n",ptr);
            ptr=strtok(NULL,tt);
        }
        int tmp=-1;
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if(i==j)    continue;
                tmp=max(tmp,gcd(a[i],a[j]));
            }
        }
        printf("%d\n",tmp);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值