Reversed Words

Time Limit: 2000 ms Memory Limit: 131072 KiB

 
Problem Description

Some aliens are learning English. They have a very strange way in writing that they revered every word in the sentence but keep all the words in common order. For example when they want to write “one two three”, they will write down “eno owt eerht”.

Now we’ve got some sentence written by these aliens, translate them! And maybe we will know some of their secrets!

Input

 Multiple test cases. The first line contains a positive integer T (T <= 1000), indicating the number of test cases.

For each test cases, there will be one line contains only lower case letters and spaces. The length of each line will be no more than 10000. Test cases which are longer than 5000 will be less than 50. Continuous letters are seen as a word, words are separated by spaces. There won’t be two adjacent spaces in the input. Space won’t be the first or the last character.

Output

 One line per case, the translated sentence.

Sample Input
2
eno owt eerht
abcde
Sample Output
one two three
edcba

大意是:给你一串字符串(包含多个有空格分隔的子字符串),将每个子字符串前后倒置后并输出。
我想了一个特别的方法:先将所有字符倒置,再从后往前输出每个子字符串。
贴下我写的代码:
#include<stdio.h>
#include<string.h>
int main ()
{
    int e;
    while(scanf("%d",&e)!=EOF)
    {
        getchar();
        while(e--)
        {
            int n,i;
            char s[10010]={0},t;
            gets(s);
            n=strlen(s);
            for(i=0;i<n/2;i++)
            {
                t=s[i];
                s[i]=s[n-i-1];
                s[n-i-1]=t;
            }
            for(i=n-1;i>=0;i--)
            {
                if(s[i]!=' ')
                    continue;
                printf("%s ",&s[i+1]);
                s[i]=0;
            }
            printf("%s\n",&s[0]);
        }
    }
    return 0;
}

 


Hint

转载于:https://www.cnblogs.com/coder-tcm/p/8627607.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值