nyoj 43 24 Point game 【经典DFS】



24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
题意:给出n个数和一个数m,问这n个数每个数只用一次(可以加减乘除 任意组合)能否得到m。
思路:用数组存储这n个数以及这n个数中任意两个之间的加减乘除的结果(记录结果时,不要用数组下标自增一,因为当前存储的结果 可能不是 正确达到m的中间的结果)。每次取没有使用的两个数,继续进行加减乘除的操作。等到操作次数达到n时,判断当前结果有没有达到m。  注意精度!
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib> 
#include <algorithm>
using namespace std;
double num[10];//记录可用数的个数n之后 继续存储n个数计算后的结果 因为最多5个数 得到结果的数组不会超过10 
bool vis[10];//标记该数或者该结果是否用过 
int n;
double m;//得到的数 
int dfs(int use, int total)//use 已使用数字个数  total 最顶的结果 在使用n个数之后每次需要检查最新结果 
{
	int i, j;
	if(use == n)
	{
		if(fabs(num[total-1] - m) < 0.000001)//精度问题 
		return 1;
		else
		return 0; 
	} 
	for(i = 0; i < total-1; i++)
	{
		if(vis[i]) continue;//已经用过
		vis[i] = true;//没用过的话标记 
		for(j = i+1; j < total; j++)
		{
			if(vis[j]) continue;//已经用过 
			vis[j] = true;
			num[total] = num[i] + num[j]; if(dfs(use+1, total+1)) return 1;
			num[total] = num[i] - num[j]; if(dfs(use+1, total+1)) return 1;
			num[total] = num[j] - num[i]; if(dfs(use+1, total+1)) return 1;
			num[total] = num[i] * num[j]; if(dfs(use+1, total+1)) return 1; 
			if(num[j])
			{
				num[total] = num[i] / num[j]; if(dfs(use+1, total+1)) return 1;
			}
			if(num[i])
			{
				num[total] = num[j] / num[i]; if(dfs(use+1, total+1)) return 1;
			}
			vis[j] = false;// 搜索失败 去掉标记 
		}
		vis[i] = false;//去掉标记 
	}
	return 0;
}
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d%lf", &n, &m);
		for(int i = 0; i < n; i++)
		scanf("%lf", &num[i]);
		memset(vis, false, sizeof(vis));//初始化 
		if(dfs(1, n))
		printf("Yes\n");
		else
		printf("No\n"); 
	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值