nyoj 43 24 Point game(深搜24点)

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No

题意:给n个数,和一个指定的数值c,将n个数用+,-,*,/,(),进行组合,所得的值能否为c

思路:深搜模拟

/*这道题用深搜非常好做,但是要注意数据为double型
第一次就因为这wa了,另外给定的表达式值不能为double型 
*/ 
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int n;
int c;
double mat[5];
int vis[5];
int flag;
int fun(double a,double b){//用来判断分母不能为零 
	if(fabs(a-b)<0.000001)
	return 1;//代表a为0 
	else return 0;//a不为0 
}
void dfs(int k,double sum)//k已选个数,sum:当前模拟的表达式值 
{
	if(flag==1) return;
	if(k==n&&fabs(sum-c)<0.000001){
		flag=1;
		return;
	}
	for(int i=0;i<n;i++)
	{
		if(!vis[i])
		{
			vis[i]=1;
			dfs(k+1,sum+mat[i]);
			dfs(k+1,sum*mat[i]);
			dfs(k+1,sum-mat[i]);
			dfs(k+1,mat[i]-sum);
			if(fun(sum,0)<0.000001)
			dfs(k+1,mat[i]/sum);
			if(fun(mat[i],0)<0.000001)
			dfs(k+1,sum/mat[i]);
			vis[i]=0;
		}
		
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		flag=0;
		scanf("%d%d",&n,&c);//c为给定的表达式值,要为int型 
		for(int i=0;i<n;i++)
		{
			scanf("%lf",&mat[i]);
		}
		for(int i=0;i<n;i++)//不确定第一个选哪个数 
		{
			memset(vis,0,sizeof(vis));//每次调用 
			vis[i]=1;
			dfs(1,mat[i]);
			if(flag==1)//代表YES,直接跳出循环 
				break;
			vis[i]=0;
		}
		if(flag==1) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值