UVA 10339.Watching Watches

 

10339 - Watching Watches

 

Time limit: 3.000 seconds 

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day. The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days. This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped). Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?
Input
Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.
Output
For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.
Sample Input
1 2

0 7
Sample Output
1 2 12:00

0 7 10:17

 

题意就是两个钟,都慢,慢的多少不同,问多久可以使得指针指的一样(时针和分针,秒针忽略)

就是转12个小时(一圈就可以呗),再加上现在的时间就可以。

无奈,小白菜,自己写的wa了,大佬给讲了也没明白式子什么意思。。。

 

代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int k,m;
    while(~scanf("%d%d",&k,&m)){
        int n=abs(k-m);
        double days=43200*1.0/n;
        int sum=(int)(days*(86400-k)/60.0+0.5)%1440;
        int hour=sum/60;
        hour%=12;
        if(hour==0) hour=12;
        int minute=sum%60;
        printf("%d %d %02d:%02d\n",k,m,hour,minute);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/ZERO-/p/7112972.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值