F - Almost Sorted Array

F - Almost Sorted Array 

 
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array. 
 
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,ana1,a2,…,an, is it almost sorted?

InputThe first line contains an integer TT indicating the total number of test cases. Each test case starts with an integer nn in one line, then one line with nn integers a1,a2,,ana1,a2,…,an. 

1T20001≤T≤2000 
2n1052≤n≤105 
1ai1051≤ai≤105 
There are at most 20 test cases with n>1000n>1000.
OutputFor each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO

//需要用到的算法:最长递增子序列


#include <iostream>
#include <cstdio>
#include <memory.h>
#include <algorithm>

#define INF 0x3f3f3f

using namespace std;

const int MAXN = 1e5 + 7;

int dp[MAXN];
int a[MAXN];
int b[MAXN];

int main() {
    int T;
    cin >> T;
    while(T--) {
        int n;
        scanf("%d", &n);
        memset(dp, INF, sizeof dp);
        for(int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            b[n - i - 1] = a[i];
        }
        //递增
        //依次遍历,将当前元素插入dp数字中适当的位置
        for(int i = 0; i < n; i++) {
            *upper_bound(dp, dp + n, a[i]) = a[i];
        }
        //求出最长递增子序列的长度
        int cnt1 = lower_bound(dp, dp + n, INF) - dp;
        //递减
        memset(dp, INF, sizeof dp);
        for(int i = 0; i < n; i++) {
            *upper_bound(dp, dp + n, b[i]) = b[i];
        }
        int cnt2 = lower_bound(dp, dp + n, INF) - dp;
        //如果最后递增和递减的长度其中有一个大于或等于(n-1)的话,就输出YES,否则输出NO
        if(cnt1 >= (n - 1) || cnt2 >= (n - 1)) {
            printf("YES\n");
        } else {
            printf("NO\n");
        }
    }
    return 0;
}

 

 



转载于:https://www.cnblogs.com/buhuiflydepig/p/10942391.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值