UVA 1149 Bin Packing 二分+贪心

 

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same
length l and each item i has length li ≤ l. We look for a minimal number of bins q such that
• each bin contains at most 2 items,
• each item is packed in one of the q bins,
• the sum of the lengths of the items packed in a bin does not exceed l.
You are requested, given the integer values n, l, l1, . . . , ln, to compute the optimal number of bins
q.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The first line of the input file contains the number of items n (1 ≤ n ≤ 105
). The second line
contains one integer that corresponds to the bin length l ≤ 10000. We then have n lines containing one
integer value that represents the length of the items.
Output
For each test case, your program has to write the minimal number of bins required to pack all items.
The outputs of two consecutive cases will be separated by a blank line.
Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered
from 1 to 10 according to the input order.
Sample Input
1
10
80
70
15
30
35
10
80
20
35
10
30
Sample Output
6

 

题意:

   给定N(N<=100000) 个物品的重量,背包的容量M,同时要求每个背包最多装两个物品,求至少要多少个背包才能装下所有的物品

题解:

  我们二分背包个数

  check的时候先自大到小填一个在每一个背包

  再从大到小填满,检查是否放完就好了

  还有就是注意输出格式

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 1e5+10, M = 30005, mod = 1e9 + 7, inf = 0x3f3f3f3f;
typedef long long ll;

int n,m,a[N],b[N];
bool check(int x) {
    int cnt = 0;
    if(x*2<n) return 0;
    for(int i=n;i>=n-x+1;i--) {
        b[++cnt] = a[i];
    }
    b[++cnt] = m;
    int sum=cnt;
    for(int i=n-x;i>=1;i--) {
        if(b[--sum]+a[i]>m) {
           // cout<<b[sum]<<" "<<a[i]<<endl;
            return 0;
        }
    }
    return 1;
}
int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        if(n==1) {
            puts("1");
            continue;
        }
        sort(a+1,a+n+1);
        //cout<<check(6)<<endl;return 0;
        int l=1, r=n,ans=n;
        while(l<=r) {
            int mid=(l+r)/2;
            if(check(mid)) r=mid-1,ans=mid;
            else l=mid+1;
        }
      //  cout<<1<<endl;
        printf("%d\n",ans);
        if(T)cout<<endl;
    }
}

 

转载于:https://www.cnblogs.com/zxhl/p/5405492.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值