【字符串题目】poj 3096 Surprising Strings

Surprising Strings
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6193 Accepted: 4036

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

题目分析:一个字符串例如:AABB,字符的两两组合为:间距为0时:AA AB BB
间距为1时:AB AB (出现相同情况,可以判断该串为 not surprise )
间距为2时: AB
代码:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <string>
#include <iostream>
#include <iomanip>
#include <algorithm>

using namespace std;

struct node
{
    char a;
    char b;
    bool operator == (const node &x)const{
        return a==x.a&&b==x.b; //重载定义==符号 判断两个结构体相等
    }
}q[10000];

int main()
{
    char s[100];
    int i, j, k, ll;
    int len;
    while(scanf("%s", s) && strcmp(s, "*")!=0 ){
        len = strlen(s);
        if(len<=2){
            printf("%s is surprising.\n", s);
        }
        else{
            bool flag=false;
            for(i=0; i<=len-2; i++)
            {
                int e=0;
                for(j=0; j+i<len; j++)
                {
                    q[e].a=s[j]; q[e++].b=s[j+i+1];
                }
                for(k=0; k<e; k++)
                {
                    for(ll=k+1; ll<e; ll++)
                    {
                        if(q[k] == q[ll]){
                            flag=true; break;
                        }
                    }
                }
                if(flag==true){
                    break;
                }
            }
            if(flag==true)
                printf("%s is NOT surprising.\n", s);
            else
                printf("%s is surprising.\n", s);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yspworld/p/4498342.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值