Aizu-ALDS1_3_A:Stack

D - Stack

Write a program which reads an expression in the Reverse Polish notation and prints the computational result.
An expression in the Reverse Polish notation is calculated using a stack. To evaluate the expression, the program should read symbols in order. If the symbol is an operand, the corresponding value should be pushed into the stack. On the other hand, if the symbols is an operator, the program should pop two elements from the stack, perform the corresponding operations, then push the result in to the stack. The program should repeat this operations.

Input

An expression is given in a line. Two consequtive symbols (operand or operator) are separated by a space character.
You can assume that +, - and * are given as the operator and an operand is a positive integer less than 106

Output

Print the computational result in a line.

Constraints

2 ≤ the number of operands in the expression ≤ 100
1 ≤ the number of operators in the expression ≤ 99
-1 × 109 ≤ values in the stack ≤ 109

Sample Input 1

1 2 +

Sample Output 1

3

Sample Input 2

1 2 + 3 4 - *

Sample Output 2

-3


解题心得:

  1. 给出的输入很简单已经是一个逆波兰表示法了,只要写一个栈来模拟一下运算的过程。
  2. 如果输入的是四则运算符号,就从栈中取出两个数字运算,得出的结果压入栈,如果输入的直接就是数字,就直接压入栈。

#include<bits/stdc++.h>
using namespace std;
string s;
int main()
{
    stack <long long> st;
    while(cin>>s)
    {
        if(s[0]>='0' && s[0] <= '9')
        {
            long long num = 0;
            for(int i=0;i<s.length();i++)
            {
                long long temp = (s[i]-'0');
                num = num*10+temp;
            }
            st.push(num);
        }
        else
        {
            long long a,b;
            b = st.top();
            st.pop();
            a = st.top();
            st.pop();
            if(s[0] == '*')
                a = a*b;
            else if(s[0] == '+')
                a = a+b;
            else if(s[0] == '-')
                a = a-b;
            else if(s[0] == '/')
                a = a/b;
            st.push(a);
        }
    }
    long long ans = st.top();
    st.pop();
    printf("%lld\n",ans);
    return 0;
}

转载于:https://www.cnblogs.com/GoldenFingers/p/9107258.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值