stack(ALDS1_3_A)

Time Limit : 1 sec , Memory Limit : 131072 KB , isSolved : --

Reverse Polish notation is a notation where every operator follows all of its operands. For example, an expression (1+2)*(5+4) in the conventional Polish notation can be represented as 1 2 + 5 4 + * in the Reverse Polish notation. One of advantages of the Reverse Polish notation is that it is parenthesis-free.

Write a program which reads an expression in the Reverse Polish notation and prints the computational result.

An expression in the Reverse Polish notation is calculated using a stack. To evaluate the expression, the program should read symbols in order. If the symbol is an operand, the corresponding value should be pushed into the stack. On the other hand, if the symbols is an operator, the program should pop two elements from the stack, perform the corresponding operations, then push the result in to the stack. The program should repeat this operations.

Input

An expression is given in a line. Two consequtive symbols (operand or operator) are separated by a space character.

You can assume that +, - and * are given as the operator and an operand is a positive integer less than 106

Output

Print the computational result in a line.

Constraints

2 ≤ the number of operands in the expression ≤ 100
1 ≤ the number of operators in the expression ≤ 99
-1 × 109 ≤ values in the stack ≤ 109

Sample Input 1

1 2 +

Sample Output 1

3

Sample Input 2

1 2 + 3 4 - *

Sample Output 2

-3
#include<iostream>
#include<stack>
#include<cstring>
#include<cstdlib>  //atoi函数文件
#include<cstdio>  //输入输出头文件

using namespace std;

stack <int> s;

int main(){
    char str[110];
    int a,b;
    while(scanf("%s",str)){
        if(str[0] == '+') {
             b=s.top();
            s.pop();
            a=s.top();
            s.pop();
            s.push(a+b);
        }
        else if(str[0]=='-') {
            b=s.top();
            s.pop();
            a=s.top();
            s.pop();
            s.push(a-b);
        }
        else if(str[0]=='*') {
           b=s.top();
            s.pop();
            a=s.top();
            s.pop();
            s.push(a*b);
        }
        else if(str[0]=='/') {
           b=s.top();
            s.pop();
            a=s.top();
            s.pop();
            s.push(a/b);
        }
        else s.push(atoi(str));
    }
    cout<<s.top()<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值