SDNU 1142.Hello World!(结构体排序)

Description

We know that Ivan gives Saya three problems to solve (Problem F), and this is the first problem.
“We need a programmer to help us for some projects. If you show us that you or one of your friends is able to program, you can pass the first hurdle.
I will give you a problem to solve. Since this is the first hurdle, it is very simple.”
We all know that the simplest program is the “Hello World!” program. This is a problem just as simple as the “Hello World!”
In a large matrix, there are some elements has been marked. For every marked element, return a marked element whose row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1 -1.
Saya is not a programmer, so she comes to you for help.
Can you solve this problem for her?

Input

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N≤1000), which represents the number of marked element.
Each of the next N lines containing two integers r and c, represent the element’s row and column. You can assume that 0<r, c≤300. A marked element can be repeatedly showed.
The last case is followed by a line containing one zero.

Output

For each case, print the case number (1, 2 …), and for each element’s row and column, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

Sample Input

3
1 2
2 3
2 3

0

Sample Output

Case 1:
2 3
-1 -1
-1 -1

Source

思路:傻乎乎的用结构体重载,做了很多次, 烦了很多大佬,就是wa。然后才知道,结构体重载不会自动排序,和优先队列结合在一起用才会有用(泪流成海)。然后改为在外部定义一个结构体的sort排序,就a了。   T^T
#include<bits/stdc++.h>
using namespace std;

#define ll long long
#define eps 1e-9
#define pi acos(-1)

const int inf = 0x3f3f3f3f;
const int mod = 1000000007;
const int maxn = 1000 + 8;

int n;

struct node
{
    int x, y;
}a[maxn], b[maxn];

bool cmp(node x, node y)
{
    if(x.x != y.x)
        return x.x < y.x;
    return x.y < y.y;
}

int main()
{
    std::ios::sync_with_stdio(0);
    cin.tie(0);
    cout.tie(0);
    int ca = 0;
    while(cin >> n && n)
    {
        for(int i = 0; i < n; i++)
        {
            cin >> a[i].x >> a[i].y;
            b[i].x = a[i].x;
            b[i].y = a[i].y;
        }
        sort(b, b + n, cmp);
        cout << "Case " << ++ca << ":" << '\n';
        for(int i = 0; i < n; i++)
        {
            int j = 0;
            while((a[i].x >= b[j].x || a[i].y >= b[j].y) && j < n)
                j++;
            if(j < n)
                cout << b[j].x << " " << b[j].y << '\n';
            else
                cout << "-1 -1" << '\n';
        }
        cout << '\n';
    }
    return 0;
}
/*
6
8 9
10 10
2 3
5 4
6 7
2 1
*/

 

转载于:https://www.cnblogs.com/RootVount/p/11478291.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值