hdu--1798--Doing Homework again(贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13847    Accepted Submission(s): 8036


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

 

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

Sample Output
0
3
5

 

/*
    Name: hdu--1798--Doing Homework again
    Copyright: 2017 日天大帝
    Author: 日天大帝
    Date: 21/04/17 15:32
    Description: 贪心,思路让当前分数大的替换当前分数小的作业 
*/
#include<iostream>
#include<queue> 
#include<cstring>
#include<algorithm>
using namespace std;
struct work{
    int score,deadline; 
    bool operator<(const work &a)const{
        return score>a.score;
    }
}arr[1005];
bool cmp(work a,work b){
    return a.deadline<b.deadline;
}
priority_queue<work> q;//按照分数排序 
int main(){
    
    ios::sync_with_stdio(false);
    
    int T;cin>>T;
    while(T--){
        memset(arr,0,sizeof(arr));
        while(!q.empty())q.pop();
        int n;cin>>n;
        for(int i=0; i<n; ++i)cin>>arr[i].deadline;
        for(int i=0; i<n; ++i)cin>>arr[i].score;
        int t = 0,ans = 0;
        sort(arr,arr+n,cmp);//按照时间排序 
        for(int i=0; i<n; ++i){
            q.push(arr[i]);
            if(t < arr[i].deadline){
                t++;continue;
            }
            ans += q.top().score;
            q.pop();
        }
        cout<<ans<<endl;
    }
    return 0;
}
/*大神的代码,优先队列和排序很巧妙*/
#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <queue>
#include <utility>
#include <vector>
#include <iterator>
using namespace std;

typedef long long ll;
typedef pair<int, int> P;
const int MAX_N = 1 << 17;
const int INF = 0x3f3f3f3f;
P arr[MAX_N];

int main() {
    //ios::sync_with_stdio(false);
    //cin.tie(NULL);
    //cout.tie(NULL);
    int T;
    scanf("%d", &T);
    while (T--) {
        int n;
        scanf("%d", &n);
        for (int i = 0; i < n; ++i)
            scanf("%d", &arr[i].first);
        for (int i = 0; i < n; ++i)
            scanf("%d", &arr[i].second);
        sort(arr, arr + n);
        int ans = 0, day = 0;
        priority_queue<int, vector<int>, greater<int> > pque;
        for (int i = 0; i < n; ++i) {
            pque.push(arr[i].second);
            if (day < arr[i].first) {
                ++day;
                continue;
            }
            ans += pque.top();
            pque.pop();
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/evidd/p/6744447.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值