HDU 1686 Oulipo (KMP 可重叠)

本文介绍了一种用于查找字符串中特定模式出现次数的高效算法——KMP算法,并通过一个具体的编程实例详细展示了如何实现该算法。文章针对比赛中常见的问题场景,提供了一个能够处理大量数据输入并快速得出结果的解决方案。
摘要由CSDN通过智能技术生成

题目链接

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

分析:

统计匹配串出现次数,可以前后重叠,所以直接计数即可

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int nxt[100005],n,m,cnt;
char a[10000005],b[100005];
void getNext()
{
    memset(nxt,0,sizeof(nxt));
    for(int i=1;i<m;i++)
    {
        int j=nxt[i];
        while(j&&b[i]!=b[j])
          j=nxt[j];
        nxt[i+1]=(b[i]==b[j])?j+1:0;
    }
}

void KMP()
{
    n=strlen(a);
    m=strlen(b);
    getNext();
    for(int i=0,j=0;i<n;i++)
    {
        while(j&&a[i]!=b[j])
          j=nxt[j];
        if(a[i]==b[j])
          j++;
        if(j==m)     //只要出现匹配成功,不必担心前后两次匹配成功的子串是否有重叠部分
          cnt++;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",b,a);
        cnt=0;
        KMP();
        printf("%d\n",cnt);
    }
    return 0;
}

转载于:https://www.cnblogs.com/cmmdc/p/7898614.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值